got some new codes...can you help? - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

got some new codes...can you help?

Reply

 
 
 
Old 10-15-2007, 09:43 PM
  #1  
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Sep 2007
Location: waukesha, WI
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Triple X is on a distinguished road
Default got some new codes...can you help?

ok i did a self cpu test and i have some new codes....


34 Mass Air Flow Sensor (grams per secone low) (NEW)

44 Oxygen Sensor Circuit (lean Exahust indicated) (NEW)


what does it mean?...lol

thanks again
Triple X is offline  
Reply With Quote
Old 10-15-2007, 11:34 PM
  #2  
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

you probably need to clean your MAF sensor. It is located directly on top of your throttle body. Then, after removing the screws and pulling out the MAF, you can spray the little wires down with some QD Electronic cleaner. If that does not work, you will probably need to replace it with a new or used one. They are very expensive new.



You also need a new oxygen sensor. It is located on the rear exhaust manifold, and looks like this, (differen connector!)



it is a good idea to use the special tool to get the old sensor off, you can rent it at most parts stores. it helps to have the exhaust WARM... not HOT or COLD



if you have more questions after this, just post them up!
harofreak00 is offline  
Reply With Quote
Old 10-16-2007, 09:04 AM
  #3  
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

I'm not positive these are new parts that are needed. Please.. use only a rubbing alcohol q tip or cleaner designed for MAF sensor cleaning.

An O2 sensor code and a MAF code can both be related to a poor ground, a large vacuum leak and a few other items.
BillBoost37 is offline  
Reply With Quote
Old 10-16-2007, 07:19 PM
  #4  
PopaDopaDo
True Car Nut
 
popatim's Avatar
 
Join Date: Jan 2005
Location: NY
Posts: 4,957
Thanks: 0
Thanked 0 Times in 0 Posts
popatim is on a distinguished road
Default

X2 - I'm with Bill on this. I'd be suspcious anytime two sensors act up at the same time.
popatim is offline  
Reply With Quote
Old 10-16-2007, 08:27 PM
  #5  
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Sep 2007
Location: waukesha, WI
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Triple X is on a distinguished road
Default

well how about this for even more weirdness...after i got off of here from my last post i went and checked to see what codes would come up again...and all three where still there....than i got kinda pissed and went to work. well when i left the check light was still on for a min and then went off...witch is what it always did with the quad "b" fault code......well as i continued to drive to see if i still had boost...the light never came back on...AT ALL! not even the ride back home....enplane that!....lol
Triple X is offline  
Reply With Quote
Old 10-16-2007, 08:35 PM
  #6  
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

That'* easy..it takes a certain amount of start cycles with failed tests for the light to illuminate. See if you get through a couple more days/cycles before getting too excited. Although If the soleniod for the BCS uses a ground..it could have drawn down those other two sensor grounds.
BillBoost37 is offline  
Reply With Quote
Old 10-17-2007, 08:49 AM
  #7  
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Sep 2007
Location: waukesha, WI
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Triple X is on a distinguished road
Default

right i guess i will justt have to wait and see
Triple X is offline  
Reply With Quote
Old 10-17-2007, 09:53 AM
  #8  
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default code

A bottle of fuel injector cleaner with water remover is a good start in a case like this. Then see if it returns. Happened twice on my 96 when we started getting cool nights.
SSEBONNE4EVA is offline  
Reply With Quote
Old 10-25-2007, 09:12 AM
  #9  
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Sep 2007
Location: waukesha, WI
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Triple X is on a distinguished road
Default

ok ....i am still getting all three of the same codes even though i fixed the boost issue. and now i am starting to have a rough idle....witch started when i disconnect the battery...since then the idle has been shitty now and then...now i know its relearning the idle but when is it going to finish?

its weird...i was going though a drive through one day and the idle was pretty bad...i was kinda making the whole car shake almost like it was missing or something....then wile still in line...out of know were the idle came back up and started running fine.

also now the check engine light goes and and off...but not like when i had the boost problem...now the light will be off for a day and then it could be on for a few days and vice versa.

now i still did not check the two sensors like you guys said but i guess i wanted to give you and update in case its something else....maybe i just need a tune up of new plugs and wires....what do you think?
Triple X is offline  
Reply With Quote
Old 10-25-2007, 11:07 AM
  #10  
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

The next time your idle acts up, disconnect your MAF sensor and see if it settles back down (the PCM uses default tables when it loses the MAF signal completely). If this improves the idle, inspect the MAF sensor wiring carefully, and if no problems are found, replace the sensor.
willwren is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sseidriver97
General GM Chat
8
07-16-2010 09:06 PM
TJ'sblackbonne
General GM Chat
27
12-22-2006 02:00 PM
MOS95B
Lounge
5
03-28-2004 03:46 AM
Drifter420
General GM Chat
4
09-04-2002 09:45 AM


Thread Tools
Search this Thread