What did you do with your car/truck or shop today? V2.0 - Page 123 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Lounge For casual talk about things unrelated to General Motors. In other words, off-topic stuff. And anything else that does not fit Section Description.

Closed Thread
 
 
 
Thread Tools Search this Thread
Old 09-18-2013, 07:45 AM   #1221
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

that herculiner is good stuff. hate the plastic its like having ice in there all the time.
jwfirebird is offline  
Old 09-18-2013, 08:49 PM   #1222
certified crazy person
Certified GM nut
 
eltatertoto's Avatar
 
Join Date: Sep 2010
Location: hobart indiana (1 hr from chicago)
Posts: 1,871
Thanked 64 Times in 52 Posts
eltatertoto is a jewel in the rougheltatertoto is a jewel in the rougheltatertoto is a jewel in the rougheltatertoto is a jewel in the rough
Default

Quote:
Originally Posted by Buick96 View Post
It doesn't matter if anything is new things still pull.. My buicks front end parts were replaced constantly it doesn't matter what you do damn things pull.. I just fixed my trucks pulling issue my pins in my calipers were seized pretty bad had to torch the caliper and pull them out.
well, today i was off with no money. so decided to put the front end on stands again. no noticeable difference between the right wheel and the left. so i had the gf put it in drive and bring it up to 50 so i could look at the wheels. the driver side is fine, but the passenger seemed to go up and down a bit. i also noticed today, the front right side is making a bad balljoint like noise hitting bumps and things.

i did take it to the tire shop and they denied any issue with that wheel. they moved it to the right rear (which is where the vibration moved to) but its still pulling pretty hard. im starting to think it could be that bearing plate thing ontop of the strut. i didnt replace it when i did my struts and im starting to think it could be causing the balljoint like noise and the pulling.
eltatertoto is offline  
Old 09-19-2013, 05:06 AM   #1223
Senior Member
True Car Nut
 
sawgunner's Avatar
 
Join Date: Jan 2009
Location: Dover, NH
Posts: 7,122
Thanks: 0
Thanked 0 Times in 0 Posts
sawgunner is on a distinguished road
Default

with weight on the wheel when you turn it it will make a popping sound if your strut mount is bad, don't know if it would really cause a pull. I didn't get the pull in my Bonnie when it'* strut mounts went bad but then again that thing never had an easy day of driving either LOL
sawgunner is offline  
Old 09-19-2013, 06:38 AM   #1224
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 338 Times in 301 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Jason did u replace both lower control arms?
Are the springs free of any coil bind like space between each coil on top & bottom areas?
If it is a bad ball joint ..how much movement in it?
When u did the alignment ....did the shop not mention after the test drive it was pulling?
If anyone should know what is wrong it should be an alignment specialist...!!!!
Soft Ride is offline  
Old 09-19-2013, 10:56 PM   #1225
certified crazy person
Certified GM nut
 
eltatertoto's Avatar
 
Join Date: Sep 2010
Location: hobart indiana (1 hr from chicago)
Posts: 1,871
Thanked 64 Times in 52 Posts
eltatertoto is a jewel in the rougheltatertoto is a jewel in the rougheltatertoto is a jewel in the rougheltatertoto is a jewel in the rough
Default

i just did the one, but the pulling was present before i did anything to the suspension in the first place. all of those parts (sans the wheel bearing) were from me trying to correct the pulling issue. im just out of parts to replace apart from the $200 axle and im at a loss. the shops always deny any pulling at all. ive taken it to sears quick lane and a goodyear owned shop. i think now its time to bite the bullet and take it to the dealer and just weed through all the BS up-selling to find the real issue at hand. the sears shop showed me the alignment sheet and everything was in spec. so im not necessarily questioning the work being done.

this has been going on for almost a year now, and i just want to get it fixed so i dont get premature wear on my cars new shoes. (aside from that, its really annoying having my spinner at the 12 o' clock position all the time. LOL)
eltatertoto is offline  
Old 09-20-2013, 08:32 AM   #1226
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if the alighnment is correct it has to be something that moves as you are accelerating like control arms, control arm bushings or something to do with the tie rods or rack
jwfirebird is offline  
Old 09-20-2013, 03:57 PM   #1227
Senior Member
True Car Nut
 
Buick96's Avatar
 
Join Date: Jan 2011
Location: Michigan
Posts: 3,344
Thanks: 0
Thanked 0 Times in 0 Posts
Buick96 is on a distinguished road
Default

Quote:
Originally Posted by eltatertoto View Post
well, today i was off with no money. so decided to put the front end on stands again. no noticeable difference between the right wheel and the left. so i had the gf put it in drive and bring it up to 50 so i could look at the wheels. the driver side is fine, but the passenger seemed to go up and down a bit. i also noticed today, the front right side is making a bad balljoint like noise hitting bumps and things.

i did take it to the tire shop and they denied any issue with that wheel. they moved it to the right rear (which is where the vibration moved to) but its still pulling pretty hard. im starting to think it could be that bearing plate thing ontop of the strut. i didnt replace it when i did my struts and im starting to think it could be causing the balljoint like noise and the pulling.
Strut mounts is what you're talking about mine needed those before I it rid of it and your problem sounds like what mine was
Buick96 is offline  
Old 09-20-2013, 06:06 PM   #1228
Senior Member
Posts like a Turbo
 
mrpontiac65's Avatar
 
Join Date: May 2009
Location: Birmingham Ia.
Posts: 339
Thanked 4 Times in 4 Posts
mrpontiac65 is on a distinguished road
Default

Well today I got a regular title to my '65 GTO finally. I bought it back in '78 and had to register it in a RED TITLE (not for highway use/ no plates but in my name). It runs but needs some work. Hope to have it back on the road by next summer. Maybe in time for the Hot Rod Power Tour.
mrpontiac65 is offline  
Old 09-20-2013, 06:50 PM   #1229
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,641
Thanked 995 Times in 772 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Don, you got any pics of this 65 GTO?
Mike is offline  
Old 09-20-2013, 07:55 PM   #1230
Senior Member
Posts like a Turbo
 
mrpontiac65's Avatar
 
Join Date: May 2009
Location: Birmingham Ia.
Posts: 339
Thanked 4 Times in 4 Posts
mrpontiac65 is on a distinguished road
Default

Here'* some pictures. It'* not in the best shape. It'* not all rotted out either.
Attached Thumbnails
What did you do with your car/truck or shop today? V2.0-img_0123.jpg   What did you do with your car/truck or shop today? V2.0-new-old-plates.jpg   What did you do with your car/truck or shop today? V2.0-img_0921.jpg  
mrpontiac65 is offline  
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
What did you do with your car/truck or shop today? V3.0 GunsOfNavarone Lounge 782 12-07-2017 10:26 PM
What did you do with your car/truck or shop today? Danthurs Lounge 3072 09-06-2017 07:37 AM
How did you hear about BC and why did you join? BLACK94SSEi Lounge 43 05-14-2006 01:00 AM
Old shop/store to new shop/store. Moving Fun... SSEimatt93 Lounge 6 01-23-2006 03:39 PM
News video of truck/car/truck crash. Amazing. randman1 Lounge 8 04-05-2005 05:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.