Stalling while driving - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-09-2016, 03:18 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2016
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
1990cutlasssupreme is on a distinguished road
Default Stalling while driving

Car idles fine now, no cel, but when i start driving it stalls and sputters ... cel comes on, starts right back up with no light. Codes come back as 33,34,35,44

Any suggestions or idea what'* going on?
1990cutlasssupreme is offline   Reply With Quote
Old 06-09-2016, 04:23 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,152
Thanked 786 Times in 615 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Might need an "Idle Learn" procedure.....

Disconnect battery, neg first, then pos.....clean throttle plate and bore...pull IAC valve, and clean pintle and mating surface......reinstall IAC.....reconnect battery, pos first....

Apply ebrake and block drive wheels ......start vehicle, remain in seat, apply brake , shift to Drive .........keep foot on brake as car idles in drive for about 10 minutes, or if coolant fan comes on.....then, shift to park, shut vehicle off...wait 10 seconds, then start and shift into drive again, with foot on brake, for about 5 minutes, then shift to park and shut car off....remove blocks, release ebrake and you should be good to go....
Tech II is offline   Reply With Quote
Old 06-10-2016, 09:24 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2016
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
1990cutlasssupreme is on a distinguished road
Default

Quote:
Originally Posted by Tech II View Post
Might need an "Idle Learn" procedure.....

Disconnect battery, neg first, then pos.....clean throttle plate and bore...pull IAC valve, and clean pintle and mating surface......reinstall IAC.....reconnect battery, pos first....

Apply ebrake and block drive wheels ......start vehicle, remain in seat, apply brake , shift to Drive .........keep foot on brake as car idles in drive for about 10 minutes, or if coolant fan comes on.....then, shift to park, shut vehicle off...wait 10 seconds, then start and shift into drive again, with foot on brake, for about 5 minutes, then shift to park and shut car off....remove blocks, release ebrake and you should be good to go....
Did exactly what you listed and no luck...now only code is 34, replaced with a known good one and now stalls as soon as i tap the gas.
1990cutlasssupreme is offline   Reply With Quote
Old 06-10-2016, 02:54 PM   #4
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,152
Thanked 786 Times in 615 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

So you replaced the MAP sensor?

Have you checked all vac lines for potential leaks?

Spray carb cleaner while moving vac lines, to see if there is a change in idle...
Tech II is offline   Reply With Quote
Old 06-11-2016, 08:11 AM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2016
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
1990cutlasssupreme is on a distinguished road
Default

Quote:
Originally Posted by Tech II View Post
So you replaced the MAP sensor?

Have you checked all vac lines for potential leaks?

Spray carb cleaner while moving vac lines, to see if there is a change in idle...
Yes sir, got a new one in and same code. Sprayed carb cleaner over all vacuum and gasket areas . no change in idle.

Took the car for a drive, at first it was rough, and a lot of hard surging and dropping idle, it eventually stopped surging and was running good. went to work and just started car and it is idling terrible again, stalls when tapping gas. engine light comes on and off(code 34)

Friend said fuel pump, but i already changed that , and fuel filter.
1990cutlasssupreme is offline   Reply With Quote
Old 06-14-2016, 07:20 AM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2016
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
1990cutlasssupreme is on a distinguished road
Default

sigh ...
1990cutlasssupreme is offline   Reply With Quote
Old 06-23-2016, 03:54 AM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2016
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
1990cutlasssupreme is on a distinguished road
Default

well code 34 still comes on ordered brand new map sensor all wiring is good. car will start right up and idle just fine and then after a while i will try to put in gear and it will throw code 34 and begin to stall and run like ****!!!!!
1990cutlasssupreme is offline   Reply With Quote
Old 06-23-2016, 10:49 PM   #8
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,152
Thanked 786 Times in 615 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

As Mike will eventually tell you, stick to one post...don't create more....
Tech II is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My '99 Eighty Eight LS Is Stalling While Driving 99 Eighty Eight Oldsmobile 2 05-29-2014 11:15 AM
Stalling while driving Aubie08 1992-1999 21 12-20-2007 02:42 AM
91 Bonneville SSE Stalling While Driving, ETC pack8926 1987-1991 7 04-11-2007 10:20 AM
92 Bonny stalling while driving?? angelfire_feb1976 1992-1999 12 02-05-2006 07:04 PM
Stalling while driving sonoma_zr2 1992-1999 3 06-26-2005 08:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:08 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.