Failed C/E light, Instrument cluster, and left signal return - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-05-2005, 01:01 AM   #11
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

Sounds like a ground to me.

Don't leave the drivers side under the hood ground loose. The one by the horn, you get ABS lights, CRAZY lights, etc.
BonneMeMN is offline   Reply With Quote
Old 07-06-2005, 12:18 AM   #12
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

OK past 24hrs I drove around and guages worked fine. I lost them for abt 5mins then back to normal. I'm pretty sure now that the right turn signal not coming on is a bulb i screwed up in the teardown. So the latest is: right turn signal no auto return and guages=intermediate problem. Am I still checking for a corroded ground?
G2SSEi95 is offline   Reply With Quote
Old 07-06-2005, 07:59 AM   #13
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

On that turn signal, pull the bulbs and put some dielectric grease into the sockets. Sounds like a corroded socket or loose bulb.
BillBoost37 is offline   Reply With Quote
Old 07-07-2005, 12:16 AM   #14
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

The main bulbs 168'* I beleive were difficult to get out of their socket, how would you get the smaller ones out?
G2SSEi95 is offline   Reply With Quote
Old 07-07-2005, 09:38 PM   #15
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

Im at work and looking for this ground but can't find it. Is there any wires going to it. Is it around mid door or further up near parking brake area? Please Help. i'm driving to Virginia tomorr and wanted to try to find problem tonight.
G2SSEi95 is offline   Reply With Quote
Old 07-12-2005, 12:55 AM   #16
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

Can someone give me an idea of where this ground is?
G2SSEi95 is offline   Reply With Quote
Old 07-12-2005, 01:22 AM   #17
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

I'm guessing.....pull the carpet back.....remove the plastic hush panel and look from there....Prolly closer to the bottom of the dash than anything.
LakevilleSSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Any recommendations for instrument cluster light bulbs for 91 Olds 88 Royale? SUPERDUDEGTA Oldsmobile 4 02-25-2015 01:26 AM
Instrument Cluster Failed - 2004 Le Sabre Doug77338 Buick 4 12-26-2012 04:37 PM
Illumination on my instrument cluster and other accessories chr0mius Everything Electrical & Electronic 7 03-22-2007 02:37 AM
Turn signal return brianj 1992-1999 7 05-07-2005 09:46 PM
Instrument cluster does not light up. (94 Bonneville) Ogantai 1992-1999 11 01-09-2005 03:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:42 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.