Electrical Problems - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-09-2005, 07:40 AM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Halifax, Canada 91SSE / 97SSEi
Posts: 5,857
Thanks: 0
Thanked 0 Times in 0 Posts
Merlin 91/97 is on a distinguished road
Default Electrical Problems

Hey all,

I think I've got some electrical issues with Knight Fire, my 97.
When the car is running she'* charging at around 13volts..... anywhere from 12.8 to 13.2... which seems kinda low.

When I plug my laptop into her she can dip as low as 11.8, and the power inverter alarm beeps almost non-stop.

Does this sound like a battery problem, alternator problem or maybe a grounding issue?

Any ideas.... anyway I can check for sure?

Thanks
Merlin 91/97 is offline   Reply With Quote
Old 07-09-2005, 12:01 PM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Best bets are to start with the usuals, clean all the battery cables and connections, including all the grounds that you can find.

Most likely I would think the regulator in the alternator is starting to break down.
BillBoost37 is offline   Reply With Quote
Old 07-09-2005, 12:21 PM   #3
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

what are you using to monitor volts, ive learned that a gague isnt always totally accurate. Go to the battery terminals with a digital meter and test from there......

i agree with Bill it sounds like the regulator is goin in the Alt.....perfect time to upgrade to the AC 140amp
1993 SLE is offline   Reply With Quote
Old 07-09-2005, 12:21 PM   #4
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

How old are the alt and battery?
willwren is offline   Reply With Quote
Old 07-09-2005, 08:18 PM   #5
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

Quote:
Originally Posted by 1993 SLE

i agree with Bill it sounds like the regulator is goin in the Alt.....perfect time to upgrade to the AC 140amp
You mean the Stock SSEi alt?

i'd check all the connections first, then outputs.
BonneMeMN is offline   Reply With Quote
Old 07-09-2005, 11:16 PM   #6
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by BonneMeMN
Quote:
Originally Posted by 1993 SLE

i agree with Bill it sounds like the regulator is goin in the Alt.....perfect time to upgrade to the AC 140amp
You mean the Stock SSEi alt?

i'd check all the connections first, then outputs.

Stock SSEi alt is 125
1993 SLE is offline   Reply With Quote
Old 07-09-2005, 11:19 PM   #7
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

Quote:
Originally Posted by 1993 SLE
Quote:
Originally Posted by BonneMeMN
Quote:
Originally Posted by 1993 SLE

i agree with Bill it sounds like the regulator is goin in the Alt.....perfect time to upgrade to the AC 140amp
You mean the Stock SSEi alt?

i'd check all the connections first, then outputs.

Stock SSEi alt is 125
KG9 - generator, 140 amp , so is this an upgrade on mine?
sonoma_zr2 is offline   Reply With Quote
Old 07-10-2005, 02:23 AM   #8
Senior Member
Posts like a Turbo
 
Join Date: Jan 2005
Location: Pawtucket, RI
Posts: 333
Thanks: 0
Thanked 0 Times in 0 Posts
LuxuriesPremier is on a distinguished road
Default

where are you measuring your voltage reading? across the battery and i assume you have an inverter that plugs into the lighter socket unless its a heavy duty one that need to connect directly to the battery.
LuxuriesPremier is offline   Reply With Quote
Old 07-11-2005, 03:05 AM   #9
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by sonoma_zr2
Quote:
Originally Posted by 1993 SLE
Quote:
Originally Posted by BonneMeMN
Quote:
Originally Posted by 1993 SLE

i agree with Bill it sounds like the regulator is goin in the Alt.....perfect time to upgrade to the AC 140amp
You mean the Stock SSEi alt?

i'd check all the connections first, then outputs.

Stock SSEi alt is 125
KG9 - generator, 140 amp , so is this an upgrade on mine?
you got lucky, most have the 125 installed
1993 SLE is offline   Reply With Quote
Old 07-11-2005, 09:08 AM   #10
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

I would check the terminals that are on the end of the battery cables. The rubber surrounds on them tend to start a lot of unknown corrosion under them. Which will affect charging and voltage travel to the batterry. Most of the common signs are weak cranking, weak running voltage, and or what seems to be a consistantly dead battery.
LakevilleSSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Problems, Problems, Problems... swartlkk 2000-2005 2 11-04-2005 08:57 PM
problems, problems, problems big_boss2010 1992-1999 15 04-25-2004 09:05 PM
electrical problems LarsonFace Audio (and aftermarket electronics) 3 07-09-2003 02:27 PM
shouldn't there be a forum for electrical related problems? bonnycrazy Forum updates and suggestions 5 05-29-2003 01:54 PM
Electrical problems gramma95 1992-1999 2 10-21-2002 09:57 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.