Illumination on my instrument cluster and other accessories - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-16-2007, 05:04 PM   #1
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default Illumination on my instrument cluster and other accessories

The illumination for my instrument cluster and A/C controls are out on my 97 GP. It'* strange, all the lights work, the warning lights and stuff, the AC controls still work, the DIC works, the only thing wrong is that when it'* dark the illumination for the instrument cluster and AC controls (I have the basic manual controls) do not go on. Is this a fuse thing? I didnt have time to check all the fuses since it'* finals week...
chr0mius is offline   Reply With Quote
Old 03-16-2007, 06:10 PM   #2
Senior Member
True Car Nut
 
Join Date: Oct 2002
Location: Groton, CT _NEBF 05, 06, 07_
Posts: 2,703
Thanks: 0
Thanked 0 Times in 0 Posts
markwb is on a distinguished road
Default

Have you tried adjusting the dimmer through its entire range a few times?
markwb is offline   Reply With Quote
Old 03-16-2007, 06:57 PM   #3
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default

Yea, I adjusted it but not like back and forth several times.
chr0mius is offline   Reply With Quote
Old 03-17-2007, 06:41 AM   #4
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default

Should I just replace the fuses or is there another problem I should be looking for? It'* the AC control and the instrument cluster illumination. Everything else works (the warning lights on the instrument cluster) just not the backlights. The other lighted things go into the dimmer night mode with the lights on and everything, just seems like the illumination for those 2 things doesnt work.
chr0mius is offline   Reply With Quote
Old 03-17-2007, 12:56 PM   #5
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

I'm thinking like Markwb that the dimmer control, or associated wiring is shot.
Archon is offline   Reply With Quote
Old 03-18-2007, 04:34 AM   #6
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default

Dimmer control works fine for the stereo and other things that dim, just the illumination all-together for those 2 components doesn't work. I guess I'll just take it into the dealership sometime next week. Checked all the fuses in the glove box, they were all fine...
chr0mius is offline   Reply With Quote
Old 03-19-2007, 01:12 PM   #7
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default

Also the lights for the hand controls on my steering wheel don't work anymore. I guess the stereo is the only thing that dims.
chr0mius is offline   Reply With Quote
Old 03-22-2007, 02:37 AM   #8
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Jan 2006
Location: Riverside, CA
Posts: 1,137
Thanks: 0
Thanked 0 Times in 0 Posts
chr0mius is on a distinguished road
Default

Any more ideas, like where the ground is for this?
chr0mius is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel sending unit wiring diagram to PCM and Instrument Cluster 2003 century macdonaldtomw Buick 2 12-25-2014 10:26 PM
instrument illumination tnjohn Buick 9 07-21-2011 04:11 PM
instrument cluster, headlights,foglights, cut in and out? 88bonnsse Everything Electrical & Electronic 11 07-06-2007 02:44 PM
Failed C/E light, Instrument cluster, and left signal return G2SSEi95 Everything Electrical & Electronic 16 07-12-2005 01:22 AM
another instrument cluster question egladman 1987-1991 4 07-03-2003 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.