Failed C/E light, Instrument cluster, and left signal return - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-03-2005, 02:42 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default Failed C/E light, Instrument cluster, and left signal return

All this week. It started with my mech tellin me when he was scanning that my c/e light wasn't wrking;maybe a burnout. Then several days later my guages began to intermediately go wacko. All but the RPM and MPH functions. So I pull the dash replace the 5 main bulbs just because and I switched the "fasten belts" bulb to the C/E light to cure the burnout and troubleshoot. I hook everything back and the clarity is great but still malfunctioning. I then read some more threads here and decided to go back in today because I hadnt sprayed the connections with the electric cleaner nor had I disassembled the the other 5 or so ribbon connections. So I did that I also tested my batt & alt w multimeter. I put it back together and still no C/E light and unit stilll malfunctioning also my left turn signal wont return automatically. I guess my cluster is sh :( ot, Right?
G2SSEi95 is offline   Reply With Quote
Old 07-04-2005, 01:11 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

The CE light doesn't work? It shouldn't unless you have a code.

All the other gauges not working is odd. Usually it'* the three gauges off to the right that go bad. Fuel usually keeps working. I suppose it could be a bad cluster.
BillBoost37 is offline   Reply With Quote
Old 07-04-2005, 01:13 AM   #3
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

Quote:
Originally Posted by BillBost37
The CE light doesn't work? It shouldn't unless you have a code.

All the other gauges not working is odd. Usually it'* the three gauges off to the right that go bad. Fuel usually keeps working. I suppose it could be a bad cluster.
yea its usually the 3 gauges far right and im tryin to figure out what the prob is
Kennginn is offline   Reply With Quote
Old 07-04-2005, 01:18 AM   #4
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

My gas guage is included in the malfunction. Along w my digital displays. My c/e light doesnt show at startup and I thought it was supp to, isn't it?
G2SSEi95 is offline   Reply With Quote
Old 07-04-2005, 01:20 AM   #5
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

u have any pics of the cluster?
Kennginn is offline   Reply With Quote
Old 07-04-2005, 01:20 AM   #6
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

Kennginn is offline   Reply With Quote
Old 07-04-2005, 01:44 AM   #7
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Cluster pic
Name:  Gauges1.jpg
Views: 1
Size:  179.2 KB
BillBoost37 is offline   Reply With Quote
Old 07-04-2005, 09:57 AM   #8
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2002
Location: Philadelphia, PA
Posts: 266
Thanks: 0
Thanked 0 Times in 0 Posts
G2SSEi95 is on a distinguished road
Default

BTW I noticed last night that when this malfunction is taking place, the right turn signal wont light either.
G2SSEi95 is offline   Reply With Quote
Old 07-04-2005, 04:47 PM   #9
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

That adds a bit of complexity since they shouldn't be connected in any way. Please try and duplicate the situation and prove or disprove the blinker. I'd think that was a flasher relay.
BillBoost37 is offline   Reply With Quote
Old 07-04-2005, 04:57 PM   #10
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Pull the carpet up to the left of your driver'* footwell....just below the doorsill and check the ground block under the carpet for corrosion.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Any recommendations for instrument cluster light bulbs for 91 Olds 88 Royale? SUPERDUDEGTA Oldsmobile 4 02-25-2015 01:26 AM
Instrument Cluster Failed - 2004 Le Sabre Doug77338 Buick 4 12-26-2012 04:37 PM
Illumination on my instrument cluster and other accessories chr0mius Everything Electrical & Electronic 7 03-22-2007 02:37 AM
Turn signal return brianj 1992-1999 7 05-07-2005 09:46 PM
Instrument cluster does not light up. (94 Bonneville) Ogantai 1992-1999 11 01-09-2005 03:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.