I finally did it! 1500w rms! - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 11-20-2010, 10:37 PM   #11
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

ill see if i can get around to making a video.... Dakota said he was gonna get a 140a alt.. which will help a tad.
raptor660 is offline   Reply With Quote
Old 11-20-2010, 11:11 PM   #12
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

Yeah im gonna build you one ..heh should be done by next weekend....Got a lot on my plate this week
sseidriver97 is offline   Reply With Quote
Old 11-21-2010, 02:11 AM   #13
-- SITE DONATOR --
True Car Nut
 
ymmot04's Avatar
 
Join Date: May 2009
Posts: 4,638
Thanked 5 Times in 4 Posts
ymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of light
Default



The guy that I worked with on my system was completely against capacitors calling them a bandaid. I see the logic behind them, but I do just fine without one and I'm pulling a total of around 1800 watts through my 5 channel amp. What made the biggest difference for me was replacing my grounds with 0 gauge wire and my positive lines got 2 gauge. Also added a second battery which is made for audio.
ymmot04 is offline   Reply With Quote
Old 11-21-2010, 05:34 AM   #14
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

So Tom, John, X ect... when u added ur second battery did u isolate it from ur other battery? how did u wire it up? I actually bought 2 Optima yellow tops a while back and was going to mount one in the trunk but changed my mind because of some things i heard.

I was told that adding a second battery would also tax my alt, so i must isolate it. whats fact? and what is Fiction?
raptor660 is offline   Reply With Quote
Old 11-21-2010, 10:52 AM   #15
Senior Member
Posts like a Turbo
 
04MonteLS's Avatar
 
Join Date: Jul 2010
Location: Sacramento, CA.
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
04MonteLS is on a distinguished road
Default

Quote:
Originally Posted by raptor660 View Post
So Tom, John, X ect... when u added ur second battery did u isolate it from ur other battery? how did u wire it up? I actually bought 2 Optima yellow tops a while back and was going to mount one in the trunk but changed my mind because of some things i heard.

I was told that adding a second battery would also tax my alt, so i must isolate it. whats fact? and what is Fiction?
Isolating it is only going to stop it from being used by the other electronics in the car, it'* still going to need to get charged so isolator or not it'* still going to be another load on your alternator.

How bad is your dimming?
04MonteLS is offline   Reply With Quote
Old 11-21-2010, 02:22 PM   #16
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

Well havent listened to it at dark yet... but my volt gauge goes down to about 8 volts so voltage drop is quite significant.
raptor660 is offline   Reply With Quote
Old 11-21-2010, 03:01 PM   #17
-- SITE DONATOR --
True Car Nut
 
ymmot04's Avatar
 
Join Date: May 2009
Posts: 4,638
Thanked 5 Times in 4 Posts
ymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of light
Default



My second battery is on an actuator that is triggered by ignition. When the car is off, the second battery is seperated from the system to prevent it from fighting with the main battery (I have heard stories both ways about whether batteries will fight or not). Another nice thing about this is that if I run one battery dead, I put in a manual switch for the actuator to kick on the second battery and I can then start the car.

Last edited by ymmot04; 11-21-2010 at 03:02 PM.
ymmot04 is offline   Reply With Quote
Old 11-21-2010, 03:33 PM   #18
Senior Member
Posts like a Turbo
 
04MonteLS's Avatar
 
Join Date: Jul 2010
Location: Sacramento, CA.
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
04MonteLS is on a distinguished road
Default

Quote:
Originally Posted by raptor660 View Post
Well havent listened to it at dark yet... but my volt gauge goes down to about 8 volts so voltage drop is quite significant.
Damn son, 8 volts???!!!

That'* crazy voltage drop. I'd definitely either not bump it that hard anymore or wire it back to 4ohms until you can get your voltage stabilized cause with your voltage dropping that low you're asking for problems far beyond frying an amp or sub. I'm gonna be honest with you, if your voltage is dropping that bad I can't imagine a 140a alt is gonna do much for you. Do you know any specs on the alt besides that? I'd be interested to know what it does at idle...I'd guess somewhere around 40-50a, you probably won't get full current out of it until about 2k rpm. How much is this alt gonna cost you? Hopefully very, very cheap as in less than $100 cause anything more than that you might as well save up for a nice 250a Mechman h/o alt or an XS Power D1400 and VCM. The battery is a 14v model and the VCM allows you to adjust the charging voltage of your battery. Mechman has a video up on YouTube that shows installation of the above setup in an older GM Truck with the stock 105a alt that'* pushing an RD Audio 1500 watt amp and two 12'*. At idle, system voltage was 16.4, at full tilt it only dropped to 16.3!

Are you really running 4ga. power wire? You really should upgrade to at least 2ga, 0ga would be best though.
04MonteLS is offline   Reply With Quote
Old 11-21-2010, 04:20 PM   #19
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

i just adjusted my gain and its not as bad... hasnt gone into the red yet but i havent really cranked it yet. I am using 4 ga wire however its not ur everyday 4 ga wire. Its Knu Koncepts. Steve meade runs this wire (im sure he uses 0 gauge tho) its very high flow. Super fine strands.
The alt is a stock 140a alt.. was looking at Power Bastards alt. but they are pricy.
http://www.powerbastards.com/products.asp?cat=131306
raptor660 is offline   Reply With Quote
Old 11-21-2010, 07:54 PM   #20
Senior Member
Posts like a Turbo
 
04MonteLS's Avatar
 
Join Date: Jul 2010
Location: Sacramento, CA.
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
04MonteLS is on a distinguished road
Default

Quote:
Originally Posted by raptor660 View Post
i just adjusted my gain and its not as bad... hasnt gone into the red yet but i havent really cranked it yet. I am using 4 ga wire however its not ur everyday 4 ga wire. Its Knu Koncepts. Steve meade runs this wire (im sure he uses 0 gauge tho) its very high flow. Super fine strands.
The alt is a stock 140a alt.. was looking at Power Bastards alt. but they are pricy.
http://www.powerbastards.com/products.asp?cat=131306
I'm very familiar with KnuKonceptz wire, you have the KLMX series 4ga. which is CCA and rated for loads of up to 100a. CCA is only 66.6% as efficient as pure copper (OFC) wire. I'm going to bet that the fuse on your power wire under the hood is larger than 100a, and also that your amp has fuses on it that total more than 100a. Not good at all.

Oh yeah, Meade doesn't run KnoKonceptz wire, FYI, he runs Fosgate wire.

Any h/o alt is gonna be pricey. Might be a good idea to go ahead and pick up that 140a alt and then just get the 14v battery and VCM and you should be golden!
04MonteLS is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How did you hear about BC and why did you join? BLACK94SSEi Lounge 43 05-14-2006 01:00 AM
I finally did it!! MOS95B Lounge 7 09-12-2005 11:41 AM
Did a little cleaning up finally Twister97 Your Ride: GM Pictures & Videos 6 01-23-2005 12:43 PM
Well my Bonneville finally did it today. egladman General GM Chat 20 11-20-2004 06:14 PM
Finally did a cardomain. 95naSTA Your Ride: GM Pictures & Videos 12 08-18-2004 01:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.