No radio, Blower is stuck on high and fans dont work!! - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-26-2010, 06:13 PM   #11
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

Im not sure if the radiator fans worked when I bought it so idk when they quit as far as the radio and my climate controls they quit at the same time. Ive checked all the fuses so far and relays are next on my list.
92BonnivilleSSEi is offline   Reply With Quote
Old 04-26-2010, 11:04 PM   #12
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

Well I got my climate controls back. As soon as I unplugged the radio they came back and as soon as I plug the radio back in they dont work. And my radio looks like it got moisture in it at one time so I think its time for a new one.
92BonnivilleSSEi is offline   Reply With Quote
Old 04-27-2010, 08:43 AM   #13
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

That'* a good start. Anything else seem to correct itself with the radio being pulled?

Do the fans work when the HVAC is on AC?
BillBoost37 is offline   Reply With Quote
Old 04-27-2010, 07:33 PM   #14
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

Havent check the radiator fans yet but everything else is back to normal once a new radio was put in!
92BonnivilleSSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dont Ask,.... Dont Tell! GXP Venom Lounge 5 03-03-2009 08:55 PM
steering wheel radio controls dont work? any ideas? 88bonnsse Everything Electrical & Electronic 1 06-30-2007 11:47 PM
Blower motor not work on high rickscorner 1987-1991 1 04-24-2007 08:29 PM
Stalled again and now radio stays on and rear defrost stuck. jordan172005 Everything Electrical & Electronic 16 03-27-2007 12:23 PM
New poem - dont read if you dont care. jwakamud Lounge 3 03-27-2007 02:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:48 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.