No radio, Blower is stuck on high and fans dont work!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-24-2010, 02:16 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default No radio, Blower is stuck on high and fans dont work!!

All of a sudden one day my radio quit workin and my blower motor is stuck on high with 3 little dashes on the display. I cleaned my ground busses and checked fuses and still cant get them to work. Also my fans dont turn on and idk how long they have not been workin. Once im done fixin these problems the car should be good to go!
92BonnivilleSSEi is offline   Reply With Quote
Old 04-24-2010, 04:02 PM   #2
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,854
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Did you check the maxifuses on the firewall?
rjolly87 is offline   Reply With Quote
Old 04-24-2010, 04:05 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

Yup all of those fuses are good idk if there is a bad relay or not.
92BonnivilleSSEi is offline   Reply With Quote
Old 04-24-2010, 05:02 PM   #4
Member
Posts like a V-Tak
 
Join Date: Mar 2010
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Velo is on a distinguished road
Default

Something I do no understand. If you blower is stuck on high and the fans are not working.
What is your problem??????
Velo is offline   Reply With Quote
Old 04-24-2010, 10:06 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

Umm the heater blows out hot air at the hottest setting on 80 degree summer day kinda gets uncomfortable sittin on leather seats. And the fans not turning on during that same 80 degree day causes the car to run at 240 degrees and thats defenatly not good on the motor so those are my problems!!!!!
92BonnivilleSSEi is offline   Reply With Quote
Old 04-24-2010, 10:33 PM   #6
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

Your engine shouldn't be reaching 240 unless you're sitting idle; the cooling fans help a little, but mainly at low speeds. Any sort of movement (outside of a traffic jam) should drop your temperatures below 200 easily. You may want to check your radiator and thermostat, just to be safe.
SignOfZeta is offline   Reply With Quote
Old 04-24-2010, 11:59 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
92BonnivilleSSEi's Avatar
 
Join Date: Mar 2010
Location: Indiana
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
92BonnivilleSSEi is on a distinguished road
Default

I just put a new theromstat in the other day. It does decrease in temp as I drive but it only goes down to about 200 degrees.
92BonnivilleSSEi is offline   Reply With Quote
Old 04-25-2010, 11:41 AM   #8
Member
Posts like a V-Tak
 
Join Date: Mar 2010
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Velo is on a distinguished road
Red face

Quote:
Originally Posted by 92BonnivilleSSEi View Post
Umm the heater blows out hot air at the hottest setting on 80 degree summer day kinda gets uncomfortable sittin on leather seats. And the fans not turning on during that same 80 degree day causes the car to run at 240 degrees and thats defenatly not good on the motor so those are my problems!!!!!
Hallo. I understand now what your problem is and it seems the fan on the radiator is not working also.
Looks to me you have two problems A/C and fan on radiator not working.
As for the A/C could be low on refrigerant, compressor not turning on and should be easy to
check.
As for the engine running hot could be a number of things but seem to be more serious and I would start with a radiator pressure check, air in the system or and I hope this is not the case
head gasket problems or other engine problems.
Hope you are able to fix this.
Velo
Velo is offline   Reply With Quote
Old 04-26-2010, 02:12 AM   #9
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

With a regular 195 thermostat, 200 is perfectly normal. Check your radiator fans first — they're more important than air conditioning.

Since you've checked your fuses and maxifuses, check your relays. Here'* a way to pull and test relays (follow Dan'* link too). I'm not sure if they're all interchangeable, though, so I'd advise against switching them around unless someone else chimes in.

If the relays are good, my Haynes manual says there are two wires from the PCM which control the fan relays — a light green/black wire from the high speed relay, and a dark green wire from the low speed relay. Make sure they're intact all the way through by checking resistance with a multimeter.

Last edited by SignOfZeta; 04-26-2010 at 02:13 AM. Reason: Fixed the link.
SignOfZeta is offline   Reply With Quote
Old 04-26-2010, 08:29 AM   #10
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Hold up guys.. seems like I just read 10 different ways out of a 4 way intersection.

Did all of the issues occur at the same time? Do you think they may have happened at different times and then shown up at the same time?

The --- hvac means it'* unhappy. Why or how, I'm not sure yet. Might be a fuse. You said the radio doesn't work. Have you checked the fuses up under the dash on the driverside? I'm not as familiar with the 92'* as the 95+. The climate system was changing over the years slightly.

Fans: Best way to find out what is going on is to scan the car. The fans will turn on at low speeds when the coolant is 216F and high speeds at 228F or when the AC is turned on. Please don't trust the dash gauge. It has a seperate sender in your year. There should be one temp probe on the back of the LIM for the gauge and one under the throttle body for the pcm to use to control the fans.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dont Ask,.... Dont Tell! GXP Venom Lounge 5 03-03-2009 08:55 PM
steering wheel radio controls dont work? any ideas? 88bonnsse Everything Electrical & Electronic 1 06-30-2007 11:47 PM
Blower motor not work on high rickscorner 1987-1991 1 04-24-2007 08:29 PM
Stalled again and now radio stays on and rear defrost stuck. jordan172005 Everything Electrical & Electronic 16 03-27-2007 12:23 PM
New poem - dont read if you dont care. jwakamud Lounge 3 03-27-2007 02:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.