Bad New Upper Rad Hose? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-05-2016, 12:38 AM   #1
Senior Member

True Car Nut
Thread Starter
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Question Bad New Upper Rad Hose?

I just got my new hoses in, and the upper rad hose looks a little deformed, trying to decide if I should return it or not.
What would you guys do?
My gut says return it.
I hope Rock Auto does not expect me to pay for return shipping, I am not the one that sent somebody a deformed part..

Attached Thumbnails
Bad New Upper Rad Hose?-btkxemy.jpg  
WilliamE is offline   Reply With Quote
Old 04-05-2016, 01:12 AM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 339 Times in 301 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Ya looks like it got bent right over... I just hope they don't do the same to you LOL..
I would want a new one! Good Luck William on the return...
Soft Ride is offline   Reply With Quote
Old 04-05-2016, 04:52 AM   #3
Senior Member

True Car Nut
Thread Starter
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

I processed a request to replace it, they are sending me a new one, and said to keep that one for 2 weeks in case the need it returned.
RockAuto has decent customer service.
WilliamE is offline   Reply With Quote
Old 04-05-2016, 04:57 AM   #4
Senior Member

True Car Nut
Thread Starter
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Amazon sent me my Mobil 1 5W 30 Extended Life oil, and my Lubeguard oil and Trans Fluid Additives the other day, and the guy said there was oil all over his truck.
So they one day shipped me the items, next day I got the oil, and the trans additive, they left out the oil additive.
Then 2 days later I get the while order, somehow they shipped it twice, so I got free oil and trans fluid additive for the next time I do it..

After that BS I had stamps coming from the post office store online, and I got a priority mail with just an invoice, and a piece of cardboard, they forgot my stamps... lol
So it has been a crazy week for getting stuff in the mail!
WilliamE is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Upper Radiator Hose gets EXTREMELY TIGHT da_grey_goose_95 1992-1999 0 07-15-2015 01:07 PM
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Goodyear Rad hose part #, 99 ssei blye 1992-1999 2 02-03-2010 03:14 PM
Park Ave has those squeeze type rad, hose clamps ok ? cvc 1992-1999 3 11-11-2006 01:03 PM
96 Bonneville upper intake hose - bye bye engine khaustic 1992-1999 7 06-19-2003 09:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.