2001 aztek BCM - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac Trans Am, Grand Am, GP's of all varieties. Fixing, Modding, and keeping Pontiacs up.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-16-2017, 07:34 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
ssumner2002 is on a distinguished road
Default 2001 aztek BCM

My father-in-law has a 2001 Aztek 3.4. He keeps experiencing an intermittent code for the camshaft position sensor. Vehicle runs good, then after a few starts won't start. The sensor has been replaced. He narrowed it down to the BCM, from what I gather based on a few other weird issues. Replaced the BCM with a used unit, but hasn't had it flashed. He is currently experiencing the same issue. I am playing middle man, seeing if anyone has had a similar issue with an Aztek/Rendevous. There'* no way to tell if the BCM is the issue until it is flashed correct?
ssumner2002 is offline   Reply With Quote
Old 04-16-2017, 09:34 PM   #2
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Elmira, NY
Posts: 15,465
Thanked 935 Times in 739 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Body Control Module has nothing to do with the engine. Engine has its own computer.

What is the code for the CPS?
Mike is offline   Reply With Quote
The Following User Says Thank You to Mike For This Useful Post:
Tech II (04-17-2017)
Old 04-17-2017, 01:35 PM   #3
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 1,913
Thanked 725 Times in 564 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Agree with Mike on this....Cam sensor is wired to the PCM, not the BCM....

When you say it won't start, do you mean it cranks over but doesn't fire, or it doesn't crank over at all?

As Mike asked, what is the exact code?
Tech II is offline   Reply With Quote
The Following User Says Thank You to Tech II For This Useful Post:
Mike (04-17-2017)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My Pontiac Aztek 2001 will turn over but not start priincess94 Pontiac 1 01-11-2017 06:31 PM
2001 Aztek Blower Control ? Wiring Issue? Teknologik Pontiac 2 10-17-2012 07:26 AM
2001 Aztek speedometer jumping and going crazy- video posted usacamaro Pontiac 7 11-29-2011 01:21 PM
Keyless Entry / All things RAC (BCM) Anything4APontiac Everything Electrical & Electronic 0 07-10-2004 12:10 AM
PONTIAC AZTEK....665 hp?? zzzzzeke Lounge 4 10-13-2003 02:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:50 PM.