oil pump replacement in 3800 in a '92 olds regency elite - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-22-2012, 04:11 PM   #1
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2012
Location: Tennessee
Posts: 25
Thanked 0 Times in 0 Posts
sheepdog2566 is on a distinguished road
Question oil pump replacement in 3800 in a '92 olds regency elite

any advice? It isn't super charged. pump kit will be here the 24 or 25... gonna start this evening. got a chilton'* repair manual, but it doesn't show much... I have never changed one like this. Got the car about 2 months ago. It'* rough but ran great! Then the oil pressure light came on (got that digital gauge thingy). Oil pressure was showing 0-8. This was after running for over an hour. Planning on cleaning the screen and tube. Already got the pan off and am cleaning it. Am replacing the oil filter and will check the oil pressure relief thing by poking with a screwdriver, should it be firm or what?. Am going to pack the devil out of the oil pump with vaseoline... Please give me any advice you can... Haven't done anything like this in 15 years and am a little rusty.... Thanks for all your help!!!
sheepdog2566 is offline   Reply With Quote
Old 01-22-2012, 04:15 PM   #2
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2012
Location: Tennessee
Posts: 25
Thanked 0 Times in 0 Posts
sheepdog2566 is on a distinguished road
Default

Oh, by the way, gonna take some pics of the replacement process, if I can I'll try to post them somewhere...
sheepdog2566 is offline   Reply With Quote
Old 01-23-2012, 07:46 AM   #3
Senior Member
Posts like a 4 Banger
 
Join Date: Aug 2011
Location: muskegon, mi
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
pbrktrt is on a distinguished road
Default

Did you hook up a mechanical gauge to check pressure? You may have nothing more than a faulty sender.
pbrktrt is offline   Reply With Quote
Old 01-23-2012, 10:18 AM   #4
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2012
Location: Tennessee
Posts: 25
Thanked 0 Times in 0 Posts
sheepdog2566 is on a distinguished road
Thumbs up

no, took off the oil filler cap and didn't see any oil in there while it was running... Had a 1.8 L in a 84 pontiac and it would have a constant stream of oil moving when I pulled the oil filler cap off... Figure it is not getting enough pressure to push the oil into the top of the engine... Got a gauge yesterday to check pressure when I finish the pump, it'* one you install but I am going to use it for a tester... Just a little nervous about doing this for a first time... Scared of screwing-up the engine... Thanks for your help...
sheepdog2566 is offline   Reply With Quote
Old 01-26-2012, 11:56 AM   #5
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
journeyforce is on a distinguished road
Default

Hello

Was the car making any noise like tapping or rattling or knocking? If not it is most likely a bad oil pressure sending unit. because an engine with no oil circulating will make an awful racket. Take the pressure gauge you just bought and hook it up to where the oil pressure sending unit is and check pressure.

I would test that first before screwing around with a new pump

Good luck
journeyforce is offline   Reply With Quote
Old 01-26-2012, 11:58 AM   #6
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
journeyforce is on a distinguished road
Default

Oh and the 1.8 was a overhead cam so that is why you saw oil being slung about when you removed the oil cap. a OHV engine is a bit different in this
journeyforce is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Timing Cover Stuck! 91 Olds Regency Elite sheepdog2566 Oldsmobile 4 12-18-2013 09:52 AM
1991 Olds 98 Elite, Two radiator fans stop working movingman Oldsmobile 17 05-31-2011 09:48 PM
1991 Olds 98 Elite..... Adam765 Oldsmobile 7 04-21-2011 12:06 PM
Idle too high on '91 Olds Regency 3800-V6 dandyd Oldsmobile 1 06-29-2010 10:46 PM
1989 olds regency series 1 or not killer_cr80r Lounge 27 10-15-2004 08:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:57 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.