ac on 2002 Bravada - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-03-2015, 01:28 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 3
Thanked 0 Times in 0 Posts
kj1956 is on a distinguished road
Default ac on 2002 Bravada

I have a 2002 Olds Bravada I bought during cold weather.The ac works good sitting in driveway but the second I put it in gear it blows the ac fuse.Not sure where to start looking for the problem.What is so strange about it is the ac works good till put in gear,so I unplugged the compressor itself ,turned ac on put in gear and it didn't shoot the fuse,plugged the compressor back up and it works fine till its put in gear.I thought the compressor was bad at first but don't understand why it only does it when I put in gear.
Any suggestions?
kj1956 is offline   Reply With Quote
Old 04-03-2015, 02:05 PM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Welcome to the forums!
That is odd that once in drive it blows.
Is it the AC fuse or the Clutch relay fuse that is blowing?

Does the clutch spin continuously in park or does it ever cycle on and off?
Do you have the correct fuse rating in there? Your owners manual or back of cover may list the correct fuse rating.
I wonder if the clutch gap may have something to do with it or high/low side pressures.
Soft Ride is offline   Reply With Quote
The Following User Says Thank You to Soft Ride For This Useful Post:
kj1956 (04-03-2015)
Old 04-03-2015, 02:09 PM   #3
Senior Member
Posts like a Turbo
 
chevy82's Avatar
 
Join Date: Jan 2014
Location: Missouri
Posts: 396
Thanked 99 Times in 84 Posts
chevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of light
Default

One theory is once its put in gear, the drive belt is putting more of a load on the compressor clutch assembly. The clutch assembly can be replaced instead of the whole compressor. Also check your grounds at the engine block. Ground wire maybe loose. (lower left side of engine)
Suppose to be a 10 amp fuse Fyi
chevy82 is offline   Reply With Quote
The Following User Says Thank You to chevy82 For This Useful Post:
kj1956 (04-03-2015)
Old 04-03-2015, 02:10 PM   #4
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,147
Thanked 781 Times in 610 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Well, I would leave the compressor attached, replace fuse and turn AC on......then carefully(moving belt), grab the harness to compressor clutch and move it about, along with other harnesses attached to it.....when the vehicle is put in gear, the harness may move and ground out somewhere......
Tech II is offline   Reply With Quote
The Following User Says Thank You to Tech II For This Useful Post:
kj1956 (04-03-2015)
Old 04-03-2015, 02:18 PM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 3
Thanked 0 Times in 0 Posts
kj1956 is on a distinguished road
Default

The clutch spin continuously in park,it is the ac fuse 10a I changed the ac relay still same results.Checked the charge on the low side and its right where its suppose to be.
kj1956 is offline   Reply With Quote
Old 04-03-2015, 03:30 PM   #6
Senior Member
Posts like a Turbo
 
Join Date: Oct 2011
Location: SC
Posts: 247
Thanked 50 Times in 43 Posts
garagerog is a jewel in the roughgaragerog is a jewel in the roughgaragerog is a jewel in the rough
Default

I'm leaning where tech II is going, there is a short somewhere when the gearshift is engaged, maybe get the Bravada on a rack or jackstands and look for a wire harness rubbing against the shift cable? just a thought, anyhow congrats on having a Bravada, I've heard they're really good vehicles with their only problem being the transfer case.

2004 Bonne SLE
1971 Chevelle SS
garagerog is offline   Reply With Quote
The Following User Says Thank You to garagerog For This Useful Post:
kj1956 (04-03-2015)
Old 04-04-2015, 08:13 PM   #7
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 3
Thanked 0 Times in 0 Posts
kj1956 is on a distinguished road
Default

Well I bought more fuses and a circuit breaker today.Plugged in the circuit breaker and it shot first thing,moved all the wires,didn't see anything,pulled the box from the console moved all the wires didn't see anything,moved the shifter back and forth several times .Started it turned on the ac worked good,put it in gear ac still worked ,went out moved wires again,drove up the road and back ac working good.I guess it will do it again sometime but for now its working.Thanks for all the info.
kj1956 is offline   Reply With Quote
Old 04-05-2015, 02:02 AM   #8
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Thanks for posting back and I hope it stays working again!
Soft Ride is offline   Reply With Quote
The Following User Says Thank You to Soft Ride For This Useful Post:
kj1956 (04-05-2015)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2k Bravada 4.3L - AC on == Hesitation swartlkk Lounge 2 05-26-2005 05:55 PM
My 2000 Olds Bravada AWD swartlkk Your Ride: GM Pictures & Videos 25 05-09-2005 09:57 PM
New upper door hinge pins for my Bravada swartlkk Lounge 0 05-01-2005 01:52 PM
Just picked up my 2000 Bravada swartlkk Lounge 4 04-30-2005 08:08 PM
All GM once again!!! Just purchased 2000 Bravada swartlkk Lounge 14 04-24-2005 04:36 PM


Tags
ac, fuse, fuse panel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.