GTX turbo build - Page 17 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-17-2012, 08:32 AM   #161
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The wire I added was only about a foot long. Only to make it look a bit cleaner. If the wire was broke the engine wouldn't start. And that'* the strange bit. I cut it out and put a new wire in and all is good. I can make no sense of it.
Danthurs is offline   Reply With Quote
Old 04-17-2012, 05:48 PM   #162
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

And, I have an empty shop now. Finally. Just did a little cleaning up on the harness, tightened a few things, tucked this and that away, strapped this back, move that over there. And then started it. Ya. Let'* start a new paragraph on that.

The PCM was sent to ZZP for the turbo tune. Nice job. First, they never changed the MAP settings. Not real bad, I just wired in a 2 bar MAP, done. It runs, but real bad. Engine was surging. No vacuum leaks. Wade band O2 was moving from 10:1afr, to off the scale lean, back and forth. That'* not right, it should settle in and smooth out, but it'* not. Hook up HPtuners, down load the tune. First thing I checked was injector flow rate. This engine has 60# injectors. They had the flow rate set to 53# It'* pouring fuel in and can't correct the problem. So I change the flow rate to 63.5#, load the tune, start it. Reset fuel trims, and it smooths out. When in open loop it'* super lean. Once it switches to closed loop, it settles in around 14.9:1. Nothing I can't deal with. So far, 2 problems with the tune that I've had to deal with. Can't say I'm surprised.

Chris took it for a little spin, and all seemed to work well. Here'* a little video of him driving past. He got on it a little bit, nothing major. You can hear the blow off valve as he goes past, that'* the puff puff puff you hear.


Finally, I have an empty, and clean shop.
Attached Thumbnails
GTX turbo build-th_2012-04-17_12-42-55_340.jpg  
Danthurs is offline   Reply With Quote
Old 04-17-2012, 05:52 PM   #163
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Good job you two!!!



Quote:
Originally Posted by Danthurs View Post
Finally, I have an empty, and clean shop.


That is until your next turbo job comes rolling in.
Mike is offline   Reply With Quote
Old 04-17-2012, 11:43 PM   #164
Member
Posts like a V-Tak
 
sweetgtx's Avatar
 
Join Date: Jul 2011
Location: cascade,wi
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
sweetgtx is on a distinguished road
Default

put some miles on it today, love the sound of that spooling, runs alittle rich, lt fueltrims looking good,no signs of kr yet only running 6 psi, tomorrow,ill give it a turn to mayb 8 or 9 psi and watch my parameters.. gotta fix the fans yet,and no cruise control either and new rear struts tomorrow.. i wanna wait till dan has some time to do a better tune on it to turn up the boost to 16-17psi,,,,, and a big shout out to all who helped with this build on this forum, and thanks again dan!!!
sweetgtx is offline   Reply With Quote
Old 04-18-2012, 11:06 PM   #165
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

We got a little more done today. Replace the rear struts. Then replaced the squeaking tensioner pulley that wasn't squeaking. It'* the alternator that'* making the noise. Then replaced the fuel line that decided it no longer wanted to keep the fuel inside the line. Nothing like opening the hood to see what is squeaking and having gas spray all over. I must say, I don't recall ever seeing Chris move so fast.

The engine seems to be smoothing out as it learns the new fuel trims. Going to give a good scan next week and tweak what is needed.
Danthurs is offline   Reply With Quote
Old 04-18-2012, 11:23 PM   #166
Member
Posts like a V-Tak
 
sweetgtx's Avatar
 
Join Date: Jul 2011
Location: cascade,wi
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
sweetgtx is on a distinguished road
Default

yea i can move like lighting when need to,,lol.. good thing the car was cold,,and i dont think it ws spraying like that on my way to your place,,cause i wood have been crispy ,,lol,, running 8lbs today, seeing 10.1-11.2 on wideband at wot.. no kr, LT'* are 00 at wot. ill b putting about 100 miles on it tomorrow for work,just babying it tho..
sweetgtx is offline   Reply With Quote
Old 04-19-2012, 08:10 AM   #167
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

A bit rich, may have to adjust that a little.
Danthurs is offline   Reply With Quote
Old 04-19-2012, 08:26 AM   #168
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Was the fuel line broken or just not seating right on the fuel rail?
Mike is offline   Reply With Quote
Old 04-19-2012, 10:45 AM   #169
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

It was broken there and had a rubber line clamped. Replaced it with a new line.
Danthurs is offline   Reply With Quote
Old 04-23-2012, 04:25 PM   #170
Retired Senior Admin

Expert Gearhead
Thread Starter
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Did a few more little things today. Found a leaking brake line, so replaced that. Pushing about 11psi boost. Here'* a little video of one of the runs.

Attached Thumbnails
GTX turbo build-th_chris.jpg  
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
To build up or not to build up. Bonnie99 Performance, Brainstorming & Tuning 4 02-08-2009 03:33 PM
Whats the difference between a GTP and a GTX Moemar Performance, Brainstorming & Tuning 3 10-10-2003 01:05 AM
GTX vs. Comp G ssesc93 Lounge 17 07-11-2003 12:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.