02 impala change oil and traction lite flashing - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-31-2017, 10:25 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
joaa is on a distinguished road
Default 02 impala change oil and traction lite flashing

I recently bought a very clean 02 impala that was draining the battery in a 3 hour span. I disconnected the amp in the trunk and cured that problem.
I discovered the harness to the radio had been cut and spliced into instead of using an adapter harness and suspicioned it had something to do with the battery drain when I heard the amp pop the speakers when I disconnected the battery and the radio didn't shut off when I opened the door.
The oil change and traction light flashes constantly and was told the gas gauge doesn't work right. Today it stalled out at about 20 MPH and knocked like a major timing issue when it restarted so I scanned it when I got home. P1361 and P1362 Both are supposed to be tied to either the crank sensor or the ICM.
I didn't get an owners manual with it so I'm at a loss at how to deal with the oil change light. I have another radio harness to splice back in with the original radio and another ICM to try but don't think that'* going to fix my flashing light problem.
Any thoughts or ideas where to look would be greatly appreciated. Thanks in advance. Joaa
joaa is offline   Reply With Quote
Old 11-01-2017, 02:17 PM   #2
Senior Member

Posts like a Turbo
 
Join Date: Feb 2015
Location: Earth
Posts: 244
Thanked 39 Times in 37 Posts
CathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura about
Default

I read somewhere else on the internet that you can access the oil-life setting through the display and controls on the radio. Hearing that the radio has been rigged various ways would seem to go hand-in-hand with this. Perhaps undoing all of the supposed improvements will resolve this?

Either way, many GM cars, I believe yours included, can reset the oil life monitor by:

1. turn on the ignition but DO NOT start the car
2. depress the accelerator pedal to the floor three times within five seconds

That having been said, I don't know if your flashing [oil change] light is actually indicating that an oil change is necessary or if it is indicating trouble of some other sort.
CathedralCub is offline   Reply With Quote
Old 11-01-2017, 10:06 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
joaa is on a distinguished road
Default

I tried a different ICM and erased the codes and drove it for an hour. Not stalling anymore and the oil light must of reset with it before I got the message how to reset it other wise.
The security light is on but not flashing and I got a crank sensor and O2 sensor code after I got back. Next I'll change the crank sensor and put the harness and original radio back in but that'* going to be awhile. My slack time just ran out and the customer always comes first. Maybe next week.
Meanwhile any volunteers to replace all five wheel studs on a 04 Taurus on the side of I -380 13 miles south of Iowa City? Thank God they're on the passenger side and thanks CathedralCub for the input
joaa is offline   Reply With Quote
Old 11-02-2017, 12:36 PM   #4
Senior Member

Posts like a Turbo
 
Join Date: Feb 2015
Location: Earth
Posts: 244
Thanked 39 Times in 37 Posts
CathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura about
Default

Quote:
Originally Posted by joaa View Post
I tried a different ICM and erased the codes and drove it for an hour. Not stalling anymore and the oil light must of reset with it before I got the message how to reset it other wise.
The security light is on but not flashing and I got a crank sensor and O2 sensor code after I got back. Next I'll change the crank sensor and put the harness and original radio back in but that'* going to be awhile. My slack time just ran out and the customer always comes first. Maybe next week.
Meanwhile any volunteers to replace all five wheel studs on a 04 Taurus on the side of I -380 13 miles south of Iowa City? Thank God they're on the passenger side and thanks CathedralCub for the input
Great to hear it'* running again. Thanks for letting us know how it turned out. Good luck with the Taurus!
CathedralCub is offline   Reply With Quote
Old 11-02-2017, 08:47 PM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
joaa is on a distinguished road
Default

Hardest part to the Taurus was getting under it to jack it up. Tomorrow afternoon I'll be working on the Impala hopefully and I'll let you know how changing the crank sensor works out.
joaa is offline   Reply With Quote
Old 11-16-2017, 08:30 PM   #6
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
joaa is on a distinguished road
Default

Runs exceptionally well with the new crank sensor and I found abs sensors disconnected on one front and one rear wheel now the traction light and abs lights are off.
I drove it for the first time last night and the dash lights don't work either. I haven't changed the radio back yet so I'll look into the dash lights then. Poor thing no tlc for quite awhile.
joaa is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1998 ABS/Traction Control Lite twaite 1992-1999 4 03-25-2010 06:10 PM
Anti-Lock and Trac off lite comes on intermittently dhaag 2000-2005 5 11-10-2006 07:50 PM
Hit a deer gut pile at 85 mph and my Air Bag lite came on travisd 2000-2005 5 04-12-2006 07:30 PM
WTF clock lite and some dials dont lite up?! fojokin Everything Electrical & Electronic 3 01-11-2005 01:43 PM
The stereo display is half lite fredbear Audio (and aftermarket electronics) 8 08-04-2004 09:12 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:33 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.