Corrosion on switch. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-23-2006, 03:50 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default Corrosion on switch.

Today I am starting my hardcore deatailing in the bonnie and I popped my switch pod out for the shift/ride/traction. and I decided to take the switch apart. I come to find some corrosion on the terminals and some light corrosion around where the LED'* go into the circuit board. Is this caused from the leaking moonroof? Nothing else in that area is corroded. Here is a blurry arse pic, but will give ya a idea.

Bonneville92V688 is offline   Reply With Quote
Old 05-23-2006, 03:59 PM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Yikes...

Does the CCR (performance and touring ride) buttons still control the struts or are they disabled already. I'm thinking you would be better off getting another pod.
BillBoost37 is offline   Reply With Quote
Old 05-23-2006, 04:02 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

I'm getting a CCR module and acclerometer from Randy (randman) and Both the lights on the pod were lit up. I was told the back struts were replaced a few years ago, so I guess I'll go searching for a switch pod after I pop in the new CCR.
Bonneville92V688 is offline   Reply With Quote
Old 05-23-2006, 05:33 PM   #4
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by Bonneville94V688
I'm getting a CCR module and acclerometer from Randy (randman) and Both the lights on the pod were lit up. I was told the back struts were replaced a few years ago, so I guess I'll go searching for a switch pod after I pop in the new CCR.
you do know that if the back struts were replaced with non CCR both your button pod lights will be on..
1993 SLE is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Guages Not working and its Not a corrosion problem...... Dutch2005 Everything Electrical & Electronic 30 08-15-2006 01:24 AM
Corrosion Control Device swartlkk Lounge 2 05-27-2005 10:05 PM
Rim Corrosion BonBon Detailing & Appearance 7 09-12-2004 11:45 PM
Brake Rotor Corrosion !! 2000SilverBullet 2000-2005 21 03-07-2004 04:40 AM
Check here for Corrosion ! jebstuart 1992-1999 2 04-21-2003 05:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.