!990 Buick Lesabre Wont Use Full RPM Range - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-17-2015, 11:27 PM   #1
Junior Member
Thread Starter
 
Forzoma's Avatar
 
Join Date: Sep 2015
Location: Illinois
Posts: 9
Thanked 0 Times in 0 Posts
Forzoma is on a distinguished road
Exclamation !990 Buick Lesabre Wont Use Full RPM Range

Im having an issue with my 90 Lesabre with 95K miles, under normal driving conditions the engine runs fine, but when i put my foot down to pass it goes up to 3500 rpms and then starts bogging, up until 4000-4500 the engine wont gain anymore Rpms and backfires until the transmission shifts into the next gear, iv be trying to diagnose this problem for a while now have replaced many things in the hope of solving this issue, things i have replaced: MAF,Crankshaft position sensor, Fuel Filter, Coil and Module, Fuel Pressure Regulator, ECM and normal tuneup items (plugs, wires, oil, ect.) it may be a timing issue as i haven't had the time to get the timing cover off and check the integrity of the timing chain, any ideas or solutions are greatly appreciated. Thank You.

Last edited by Forzoma; 09-17-2015 at 11:30 PM.
Forzoma is offline   Reply With Quote
Old 09-17-2015, 11:49 PM   #2
Senior Member
Posts like a Supercharger
 
Join Date: Jul 2015
Location: Chico, California (USA)
Posts: 158
Thanked 20 Times in 18 Posts
1.8TTony will become famous soon enough1.8TTony will become famous soon enough
Default

Broken or clogged catalytic converter or muffler?????

I had a similar problem with a Volkswagen Passat about a year ago. The car would drive fine during low rpm'*, but when I would try to accelerate at a brisk pace, the engine would rev up to a certain rpm and then it was like the engine hit a brick wall.......wouldn't rev any higher, engine would backfire and had a considerable amount of power loss. The problem turned out to be a broken catalytic converter. $1,200 dollars for a new cat and it was back on the road.......I sold sold the car 5 days later.

Last edited by 1.8TTony; 09-17-2015 at 11:50 PM.
1.8TTony is offline   Reply With Quote
The Following User Says Thank You to 1.8TTony For This Useful Post:
Forzoma (09-18-2015)
Old 09-17-2015, 11:55 PM   #3
Junior Member
Thread Starter
 
Forzoma's Avatar
 
Join Date: Sep 2015
Location: Illinois
Posts: 9
Thanked 0 Times in 0 Posts
Forzoma is on a distinguished road
Default

the same happened to me so i removed it its currently straight piped to a glasspack, i appreciate the quick response though
Forzoma is offline   Reply With Quote
Old 09-18-2015, 12:12 AM   #4
Junior Member
Thread Starter
 
Forzoma's Avatar
 
Join Date: Sep 2015
Location: Illinois
Posts: 9
Thanked 0 Times in 0 Posts
Forzoma is on a distinguished road
Default

however it used to be much worse it would chugg and chuff at 2500 rpms then i replaced the ECM and it solved alot of the issues this is my final barrier untill its a perfectly good running car.
Forzoma is offline   Reply With Quote
Old 09-18-2015, 12:29 AM   #5
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,855
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Are you getting any Trouble Codes? Is the Service Engine Soon light coming on and going out as it should, not working at all, or shining your way home?
rjolly87 is offline   Reply With Quote
The Following User Says Thank You to rjolly87 For This Useful Post:
Forzoma (09-18-2015)
Old 09-18-2015, 12:30 AM   #6
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,855
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Also, why were the parts replaced that were replaced? Are you throwing parts at it hoping something sticks or did you suspect something based on info you had?
rjolly87 is offline   Reply With Quote
The Following User Says Thank You to rjolly87 For This Useful Post:
Forzoma (09-18-2015)
Old 09-18-2015, 12:36 AM   #7
Junior Member
Thread Starter
 
Forzoma's Avatar
 
Join Date: Sep 2015
Location: Illinois
Posts: 9
Thanked 0 Times in 0 Posts
Forzoma is on a distinguished road
Default

the only trouble code is for the maf being unplugged it wont run with it plugged in? as far as the parts iv replaced it was under the assumption the engine was running lean under high rpm, and the electronics controlled by the ecm were malfunctioning but they were fixed when the new one was used, and things that needed replaced as they were still 25yr old parts in need of replacement.
Forzoma is offline   Reply With Quote
Old 09-18-2015, 12:43 AM   #8
Junior Member
Thread Starter
 
Forzoma's Avatar
 
Join Date: Sep 2015
Location: Illinois
Posts: 9
Thanked 0 Times in 0 Posts
Forzoma is on a distinguished road
Default

i will have to link a video soon to explain a bit better, its a strange issue that i have never experienced before.
Forzoma is offline   Reply With Quote
Old 09-18-2015, 11:16 PM   #9
Junior Member
Posts like a Ricer Type-R
 
Join Date: Sep 2015
Location: Coeur d'Alene Idaho
Posts: 17
Thanked 5 Times in 4 Posts
CDAJoe is on a distinguished road
Default

did you pull the codes via the check engine light or did you use a scan tool? The Scan tool if it is the more advanced ones can give you info on what your sensors are seeing.
CDAJoe is offline   Reply With Quote
The Following User Says Thank You to CDAJoe For This Useful Post:
Forzoma (09-20-2015)
Old 09-18-2015, 11:27 PM   #10
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,143
Thanked 780 Times in 609 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

If it won't run with the MAF connected, you probably need a MAF....I know you said you replaced it, but was it a used one or reman? Those reman'* can be bad right out of the box.....
Tech II is offline   Reply With Quote
The Following User Says Thank You to Tech II For This Useful Post:
Forzoma (09-20-2015)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
96 Buick LeSabre died and wont start DavisM38 Buick 5 06-26-2014 06:43 PM
RPM irrégulier Buick allure CXS g.nicole Buick 10 02-19-2014 03:12 PM
Buick century rpm gauge vladbuick Buick 1 06-29-2013 10:26 PM
SSEi wont rev over 4000 RPM HELP! chewy_mxer 2000-2005 21 10-02-2009 10:27 AM
car idles @ 3500 rpm at start and 1900 rpm in drive? 88bonnsse 1987-1991 15 01-27-2008 04:41 AM


Tags
buick, engine, lesabre custom, problems, timing chain

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.