94 buick park avenue ultra fuel pump - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-28-2016, 01:59 AM   #1
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Firebird91 is on a distinguished road
Default 94 buick park avenue ultra fuel pump

This car has a new fuel pump, went properly grounded, the horn sounds when the pump cuts on, as well as when the brake pedal is pressed. The pump kicks on at start then will not build pressure.
Firebird91 is offline   Reply With Quote
Old 05-28-2016, 02:28 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,148
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

I "assume" this did not happen BEFORE the new fuel pump was put in?

Did these guys put the fuel pump in, or did you?

Attached Thumbnails
94 buick park avenue ultra fuel pump-stooge.jpg  
Tech II is offline   Reply With Quote
The Following User Says Thank You to Tech II For This Useful Post:
Mike (05-28-2016)
Old 05-28-2016, 03:57 PM   #3
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

LMAO, wow. That is one gremlin.
Mike is offline   Reply With Quote
Old 05-29-2016, 12:26 AM   #4
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Your car is possessed. Usually when an evil spirit possessed these car, the best suggestion is to check battery and grounding cables for corrosion and tightness, as well as ground buses, up near the front of the front doors under the carpet.
rjolly87 is offline   Reply With Quote
Old 05-29-2016, 02:40 AM   #5
Senior Member

Posts like a Turbo
 
Join Date: Feb 2015
Location: Earth
Posts: 243
Thanked 39 Times in 37 Posts
CathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura about
Default

Maybe pull the horn relay and see if symptom persists? This would tell you if the issue is pre-relay or post.
CathedralCub is offline   Reply With Quote
Old 05-30-2016, 09:20 PM   #6
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Firebird91 is on a distinguished road
Default

No not till after the new pump. All grounds are good and not enough corrosion to cause concern. I have pulled the relay and instead up the horn sounding all that is heard is a steady clicking from the relay block under the dash
Firebird91 is offline   Reply With Quote
Old 05-31-2016, 01:25 PM   #7
Senior Member
Posts like a Turbo
 
shawn_s's Avatar
 
Join Date: Jun 2014
Location: Madison Wi.
Posts: 267
Thanked 42 Times in 32 Posts
shawn_s has a spectacular aura aboutshawn_s has a spectacular aura aboutshawn_s has a spectacular aura about
Default

Was the fuel pump an OE replacement? Or aftermarket?? Did you have to install a new fuel pump connector? If so maybe its wired improperly.
shawn_s is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buick Park Avenue Ultra's FTW!!!! OLBlueEyesBonne Your Other Rides: Pics & Videos 11 01-15-2008 10:30 PM
Need wiring diagram -1994 Park Avenue Ultra fuel pump relay OLBlueEyesBonne Everything Electrical & Electronic 2 02-22-2007 06:52 PM
Buick Park Avenue Ultra '00OHIOBONNESSEi General GM Chat 13 06-26-2006 09:32 PM
1994 Buick Park Avenue Ultra egladman General GM Chat 13 10-20-2003 11:11 PM


Tags
1994 buick park avenue, electrical problem, horn relay

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.