ELECTRICAL MADNESS!! - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 02-01-2005, 10:52 PM   #11
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

OK do this....
5 steps to getting an AC 140 amp alternator


1 go to advance
2 tell them you want an AC delco 140 amp alternator
3 tell them you have an SE with the heated windshiled
4 tell them L27 non */C
5 install 140 amp alternator

BTW the way there are 2 L27 and possibly more that have the 140 amp installed on there car............ Including me
1993 SLE is offline   Reply With Quote
Old 02-01-2005, 10:59 PM   #12
Senior Member
Posts like a Corvette
 
Join Date: Jul 2004
Location: Bolingbrook, IL Location: Clarkston, MI
Posts: 1,256
Thanks: 0
Thanked 0 Times in 0 Posts
llBlazin_llLo is on a distinguished road
Default

Yep my '94 Port has a L27 and it just bolted right up.
llBlazin_llLo is offline   Reply With Quote
Old 02-01-2005, 11:04 PM   #13
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Replace the battery and alternator TOGETHER if either are over a year old, or you'll get yourself in the nasty cycle of one or the other every other year.

A weak battery can stress an alternator. A weak alternator can stress a battery.

The first time you replace one and not the other, you risk starting the cycle. Sounds like what happened to you.
willwren is offline   Reply With Quote
Old 02-01-2005, 11:21 PM   #14
Senior Member
Posts like a Corvette
 
Join Date: Jan 2003
Posts: 1,250
Thanks: 0
Thanked 0 Times in 0 Posts
bmsgaffer86 is on a distinguished road
Default

i replaced my 105 amp alternator with a 140 amp one almost 9 months ago, its a drop in replacement. It has been working excellently ever since...

I need a new battery tho, cause my alt is working hard to charge it when its really cold out.
bmsgaffer86 is offline   Reply With Quote
Old 02-02-2005, 12:22 AM   #15
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

yes replace the batt and the alt. they will work better together when they are both new
1993 SLE is offline   Reply With Quote
Old 02-02-2005, 07:10 PM   #16
Senior Member
Posts like a Corvette
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

If you dont change both out at one time, which u should, but if you dont, at least charge the battery you have on there before you install a new alt. that can make a difference sometimes too.
jachin is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Grand Rapids Madness Chad V Lounge 16 05-27-2005 09:39 AM
NGK midnight madness street drags big_news_1 General GM Chat 3 07-05-2004 12:27 AM
March Madness MOS95B Lounge 3 03-05-2004 05:13 PM
More ebay madness BonneMeMN Lounge 4 02-16-2004 12:44 AM
Stop the MADNESS Jim W Bonneville GXP/ Northstar Powered Cars 23 11-02-2003 09:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.