Transmission not shifting correctly - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-20-2015, 09:07 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2015
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
gonzo_8 is on a distinguished road
Default Transmission not shifting correctly

Good evening everyone. New here. So, it all started two days ago. I was driving home and the car started to shift very hard through all the gears. I did a little research and found that the pressure control valve has issues, but is also intermittent. Well, i got the car home and let it sit for 15 minutes. I went back out and drove the car around the block and it didn't shift hard at all. But, just for precaution, I did a fluid and filter change. All was well until leaving work. I got on the road and watched the tach jump up to 4k before shifting. Then when it did shift, the same thing happened. Tach went to 4k before going into second. Now, I know that the car has problems with the torque converter also. Could it be shot, or is the valve body gone? Really appreciate the help.
gonzo_8 is offline   Reply With Quote
Old 11-21-2015, 11:26 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,148
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Have you checked condition and level of transmission fluid?

Have you checked for transmission codes?
Tech II is offline   Reply With Quote
Old 11-22-2015, 01:50 PM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2015
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
gonzo_8 is on a distinguished road
Default

Well, I feel like a complete dumb ***. So, after hours of research, i kept coming across people having issues with the tps. I remembered that a few days before I was changing the thermostat. Well, I went back under the hood and found the tps unplugged. Plugged it back in and voila. Everything is ok.
gonzo_8 is offline   Reply With Quote
The Following User Says Thank You to gonzo_8 For This Useful Post:
Soft Ride (12-02-2015)
Old 11-22-2015, 06:19 PM   #4
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Ha ha, glad it was easy to fix!
Thanks for sharing what it was with us!
WilliamE is offline   Reply With Quote
The Following User Says Thank You to WilliamE For This Useful Post:
Soft Ride (12-02-2015)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'94 Cutlass Supreme Trans not shifting correctly Gary1160 Oldsmobile 4 01-01-2013 08:04 PM
Transmission not shifting correctly Tuffguy610 1992-1999 7 11-23-2007 12:33 PM
my dic is not working correctly? lol ...95 se 88bonnsse Everything Electrical & Electronic 8 07-19-2007 02:18 PM
Power locks not working correctly alec_b 1987-1991 9 02-05-2005 04:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:49 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.