Car shuts off while driving - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-11-2009, 02:54 PM   #11
Junior Member
Thread Starter
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
bigfish87 is on a distinguished road
Default

I do not think it is the vats.... i just brought it to my mechanic, whose my neighbor and our trusty family mechanic and as we looked at it, we had it in park and the rpms would fall to 300-400 and the ses light would blink on and then it would rev back up to about 1000 rpms. it would smooth idle for about 10-20 seconds and repeat the drop in rpms and then rev back up.... ses light never stayed on. he hooked a volt meter up to it and it didnt seem to be the alt. wondering if i took it to a dealership if i could get some better answers or if they r just gonna wantto bend me over and take a bunch of money. my mechanic said he has heard of coolant dripping on a crank sensor causing a similar problem but my car has no signs of anything leaking besides an oil drip once in a geat while. Basically stumped as all hell.

Last edited by bigfish87; 05-11-2009 at 03:01 PM.
bigfish87 is offline   Reply With Quote
Old 05-11-2009, 02:57 PM   #12
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

That'* a anti theft system. I know how to bypass it on 92-99 but not the 2000+ If you do find the problem, please post it.
Danthurs is offline   Reply With Quote
Old 05-29-2009, 01:41 PM   #13
Junior Member
 
Join Date: May 2008
Location: Muskegon, Mi
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
afieroman is on a distinguished road
Default

I have the same problem... But I have codes for the EGR reading not enough flow (1403) I think. Someone walked off with my scanner! Its been popping other codes for EGR. Bumper above tailpipe is black. I put old egr in today runs better and exhaust smells better. But you can hear a drum beat sounds in exhaust. not a miss but sounds like someone playing the drums in the muffler ( like boom boom) and the exhaust will puke lite black smoke for a second. But I also have a cracked vac line coming off T Body going to fuel regulator. Heading to get now. Will repost after i get out of work if this helps or not...
afieroman is offline   Reply With Quote
Old 05-30-2009, 01:15 AM   #14
Member
Posts like a V-Tak
 
Join Date: Mar 2004
Location: Portland, OR
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
EasyE is on a distinguished road
Default

This may sound a bit too funny/obvious, but how is your coolant reservoir level? I had a similar issue in my old '93 T-bird that stumped the hell out of me for weeks. After a thermostat replacement and coolant change it would still die intermittantly when hot. I finally found a very small leak in the lower radiator hose. After repairing that and keeping the coolant topped off, it went away. When you say it only happens when hot, that'* what made me think cooling system.
EasyE is offline   Reply With Quote
Old 06-02-2009, 01:14 PM   #15
Junior Member
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
snglusk is on a distinguished road
Default

I have had the same exact symptons as of the last two weeks. I brought it in to my local mechanic and he states I need a crank sensor. I was searching out here to see how difficult it is to replace the crank sensor...any one that can tell me how difficult it is?
snglusk is offline   Reply With Quote
Old 06-02-2009, 01:19 PM   #16
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Danthurs is offline   Reply With Quote
Old 06-04-2009, 01:19 AM   #17
Senior Member
Posts like a Turbo
 
ZeeVert's Avatar
 
Join Date: Jan 2006
Location: Brighton, Michigan
Posts: 255
Thanks: 0
Thanked 0 Times in 0 Posts
ZeeVert is on a distinguished road
Default

This may sound stupid, but have your battery checked. It may be borderline. I've had it happen to me and others. Symptons will usually happen at low rpms, low speed when the alternater output is low and the true nature of your battery reveals itself. ECMs and ignitions really like to have the minimum voltage.

Good luck whatever it is.
ZeeVert is offline   Reply With Quote
Old 06-04-2009, 11:59 PM   #18
Junior Member
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
snglusk is on a distinguished road
Default

I had been messin with the batter terminals and all about a month ago while replacing the starter...they were all clean and fine. Ended up taking this one in to the shop...it was (per my mechanic) the crankshaft sensor.

Thanks for the instructions though!
snglusk is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine shuts off while driving without warning cmcmillan3366 Chevrolet 10 07-07-2014 07:34 AM
2001 lesabre shuts off while driving HELP Cosmo Buick 1 02-09-2013 09:32 AM
driving lights off while driving 99bonne Audio (and aftermarket electronics) 2 01-25-2008 02:30 AM
car dies while driving then wont start for a while..? help 88bonnsse 1987-1991 23 05-29-2007 10:30 PM
car shuts off while shifting gears ptrfair 2000-2005 9 05-05-2007 12:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.