Engine Swap - Page 4 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-02-2006, 04:34 PM   #31
Senior Member
True Car Nut
Thread Starter
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

Dude those are sweet. my neighbor had one with the original 5L from 87 with 350k on it all, and then it finally starting blowing electronics left and right then they sold it for $300. I so should have hit that thing instead of the corsica back at the time. *******' wagon!

Caddy has the 4.5 and yeah i was thinking about putting it in the b'ville, because it has the a 440t4 amazingly! At least that'* what the pan looks like. Damn thing is a pos and i want it gone though, so screw that... that 3800 will be plenty fast, plus a helluva lot better than the 12mpg i'm averaging now.
opensourceguy is offline   Reply With Quote
Old 11-09-2006, 06:01 PM   #32
Senior Member
True Car Nut
Thread Starter
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

Well folks... ol pearl rides again! There were a lot of fighting parts, and a lot of shop complications, but she runs, drives, and everything in between. It still needs some new brake lines and an alignment, but beyond that, nothing, as of yet.

I do have a few quick questions. There is one minor drivability problem where if I give more than gramma gas it'll sputter from a stop, and the SES light will flash on and off with the sputter. And once the car gets up to temp [literally as soon as the car is hot enough for TCC] the SES light will come on solid. I haven't pulled the codes yet, but tomorrow i'm going to hook it up to the scanner and see what it says. I remember back when the car used to run, I didn't have a sputter problem, but I had some non-repeatable QDM problems that worked themselves out.

The other thing, is the trans seems to have delayed engagement... not sure if it really does, but with maybe 1/3 throttle it will shift at like 3-3.5k 1-2 and 2-3. It only has a downpipe on it right now, so it'* very loud, and I can tell slightly by the exhaust tone that it might be shifting a bit late. I still have to check the obvious, but it'* been so long since I've driven this car, and now i have the 3.33... so it could just be that. Next time I will pay more attention to the speed.

All in all, this car is freakin' sweet. My mom'* 2yr old bug doesn't even compare to how nice this car is. I gotta say ol' pearl be helluva car.
opensourceguy is offline   Reply With Quote
Old 11-10-2006, 10:35 AM   #33
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

Quote:
Originally Posted by opensourceguy
Well folks... ol pearl rides again! There were a lot of fighting parts, and a lot of shop complications, but she runs, drives, and everything in between. It still needs some new brake lines and an alignment, but beyond that, nothing, as of yet.

I do have a few quick questions. There is one minor drivability problem where if I give more than gramma gas it'll sputter from a stop, and the SES light will flash on and off with the sputter. And once the car gets up to temp [literally as soon as the car is hot enough for TCC] the SES light will come on solid. I haven't pulled the codes yet, but tomorrow i'm going to hook it up to the scanner and see what it says. I remember back when the car used to run, I didn't have a sputter problem, but I had some non-repeatable QDM problems that worked themselves out.

The other thing, is the trans seems to have delayed engagement... not sure if it really does, but with maybe 1/3 throttle it will shift at like 3-3.5k 1-2 and 2-3. It only has a downpipe on it right now, so it'* very loud, and I can tell slightly by the exhaust tone that it might be shifting a bit late. I still have to check the obvious, but it'* been so long since I've driven this car, and now i have the 3.33... so it could just be that. Next time I will pay more attention to the speed.

All in all, this car is freakin' sweet. My mom'* 2yr old bug doesn't even compare to how nice this car is. I gotta say ol' pearl be helluva car.
did you replace the plugs and the wires?

and check your tv cable adjustment. tho the gx3 does rev higher then the lower gear ratio bonne'*
DarkShadow is offline   Reply With Quote
Old 11-10-2006, 10:55 AM   #34
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

OSG... the bottom? OMG.. Randman and I took it out the top.. much easier..

Flashing light usually means catalyst damaging condition. Check for bad coil or plugs wires as mentioned.
BillBoost37 is offline   Reply With Quote
Old 11-10-2006, 11:03 AM   #35
Junior Member
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
wjcollier07 is on a distinguished road
Default

w00t, OSG is back into some LN3 power!!! Welcome back to the 3800 Hopefully the gearheads can get you problem sorted out. I will take a look in the FSM and see what I can find out.
wjcollier07 is offline   Reply With Quote
Old 11-11-2006, 12:14 AM   #36
Senior Member
True Car Nut
Thread Starter
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

Plugs not replaced, but good. Wires are old, but maybe 1.5-2yrs but with less than 500miles; beldens

Okay, read the codes now. TCC failure, and QDM failure. Stupid QDM crap back to haunt me. I knew it was the ECU back then, sure enough it is. And TCC failure is weird, because the TCC works fine. Doesn't shudder on or off.

The other thing though, my FPR seems to be leaking a bit in the vacuum lines. I'm not 100% sure, but it would go with some of my minor problems. The idle is 1500 cold and 1100 warm, the motor without load doesn't like to rev... like if I floor it with no load it takes almost a full second to get to 4k from idle. But the motor runs smooth, no timing retard, and o2 readings seem normal. I need to do a fuel pressure test to confirm all this, and see if I have a leaky injector.

Also now that I got a bit more gas in the girl, the studdering off idle isn't as bad, and it doesn't do anything with the SES light. If it was on it'll stay on, if it was off it'll stay off. The fillup leads me to believe it'* fuel related, IE FPR.

Bill: yeah i realize it was a mistake now.. but it'* all done now. Worked out for the best, learned the most... got it all done. Now I just have to work out the quirks.
opensourceguy is offline   Reply With Quote
Old 11-11-2006, 01:28 AM   #37
Senior Member
True Car Nut
 
Join Date: Jul 2003
Location: Toronto, Ontario, Canada
Posts: 5,158
Thanks: 0
Thanked 0 Times in 0 Posts
repinS is on a distinguished road
Default

Higher revs with the GX3 is kind of normal. Totally killed my gas mileage when I always was hitting 2500-3000rpm out of first when TRYING to pussyfoot around town.

The exhaust sure did sound good at 2500, though.
repinS is offline   Reply With Quote
Old 11-11-2006, 03:15 AM   #38
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

Quote:
Originally Posted by opensourceguy
Plugs not replaced, but good. Wires are old, but maybe 1.5-2yrs but with less than 500miles; beldens

Okay, read the codes now. TCC failure, and QDM failure. Stupid QDM crap back to haunt me. I knew it was the ECU back then, sure enough it is. And TCC failure is weird, because the TCC works fine. Doesn't shudder on or off.

The other thing though, my FPR seems to be leaking a bit in the vacuum lines. I'm not 100% sure, but it would go with some of my minor problems. The idle is 1500 cold and 1100 warm, the motor without load doesn't like to rev... like if I floor it with no load it takes almost a full second to get to 4k from idle. But the motor runs smooth, no timing retard, and o2 readings seem normal. I need to do a fuel pressure test to confirm all this, and see if I have a leaky injector.

Also now that I got a bit more gas in the girl, the studdering off idle isn't as bad, and it doesn't do anything with the SES light. If it was on it'll stay on, if it was off it'll stay off. The fillup leads me to believe it'* fuel related, IE FPR.

Bill: yeah i realize it was a mistake now.. but it'* all done now. Worked out for the best, learned the most... got it all done. Now I just have to work out the quirks.
if ur using the plugs that i had in that engine, replace them now. theyre junk, i only put them in there to cover up the spark plug holes while the engine was out of the car.
DarkShadow is offline   Reply With Quote
Old 11-11-2006, 09:59 AM   #39
Senior Member
True Car Nut
Thread Starter
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

dammit.... those were the plugs I used. Were they at least for that motor? They're going to cut it. If not, i'll have to mixmatch TR55s and RL45s.

I keep blowing brake lines! Damn rusty pieces of junk! /end rant

DS: you wouldn't still happen to have that ECU would ya?
opensourceguy is offline   Reply With Quote
Old 11-11-2006, 12:55 PM   #40
Senior Member
Posts like a Northstar
 
bastard's Avatar
 
Join Date: Nov 2005
Location: Arkansas
Posts: 694
Thanks: 0
Thanked 0 Times in 0 Posts
bastard is on a distinguished road
Default

Put in 6 NEW plugs AC R45LTS6 and see where that gets you.
And if I understand you correctly, you don't have a long enough exhaust pipe on the car. This will make a huge difference in performance.
Doesn't Michigan have inspections for emissions and noise? How did you get a car with no mufflers past that?
bastard is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine Swap with an Idle Engine Buck Pontiac Bonneville 14 07-15-2013 11:43 AM
top swap or engine swap 99bonne Performance, Brainstorming & Tuning 3 01-26-2008 08:31 PM
seat swap and dash swap? largegoldencar 1987-1991 9 04-26-2005 12:34 AM
SER2 Pulley swap vs. SER1 Pulley swap BonEvilSSEi General GM Chat 2 10-06-2004 08:25 PM
LS1 Engine Swap? jasonapr78 Performance, Brainstorming & Tuning 21 09-23-2002 12:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.