1990 Bonne SE Part Throttle Stumble - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-28-2011, 11:01 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Location: Minneapolis, MN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
wiley3800 is on a distinguished road
Default 1990 Bonne SE Part Throttle Stumble

This one has me stumped. Car sat outside all winter (fuel pump quit) Had fuel pump and filter replaced two weeks ago - when I picked up the car from the shop, it started and idled fine until I got about 1 block away, then it was acting like the ECM hadn't gotten
itself dialed in yet(loss of power,part throttle stumble,dies at idle) I drove it on city streets out to the freeway about 4-5 miles - this is usually enough drive time to reset the ECM - if I shut the ignition off and restart right away it runs fine for about 20-30 seconds,
then starts missing,stumbling,etc. Full throttle is fine, doesn't skip a beat. I have tapped hard on the ECM(no effect) disconnected the MAF(no effect)Seafoamed it through the vacuum line in the throttle body - poured the last half of the Seafoam it the tank,thinking I
may have a sticky injector. I haven't yet checked the connector to ignition module(remember car sat outside all winter-under the hood it shows),haven't checked IAC yet,
or EGR. Will have some time this weekend to do some more troubleshooting. Am I
missing something obvious? I want this car running right as I am planning on selling it.Car ran perfect last fall B4 fuel pump quit -had just done new coil pack,plugs,wires. No codes
set by ECM. Anyone have any ideas? Thanx.
wiley3800 is offline   Reply With Quote
Old 06-28-2011, 11:14 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The idle changing after 20-30 seconds has me thinking O2 sensor. The first 20-30 seconds the engine runs without the O2 sensor and then stitches to real time data.
Danthurs is offline   Reply With Quote
Old 06-28-2011, 11:40 PM   #3
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

I also am thinking bad gas, as it has been sitting all winter. Run it down, and fill it up. See how it is doing after 2-3 tanks.
rjolly87 is offline   Reply With Quote
Old 06-29-2011, 07:27 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

x2 with rj, gas dont like sit for too long, you could throw some stabil in it and fill it with fresh hopefully it will come around
jwfirebird is offline   Reply With Quote
Old 06-29-2011, 11:33 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Location: Minneapolis, MN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
wiley3800 is on a distinguished road
Default

Thanks everyone for the input, Hopefully I will have it fixed this weekend, will post when I have more info.
wiley3800 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check engine light eliminates off idle stumble. 57lxi 1992-1999 7 05-17-2007 07:45 AM
1990 GM Commercial "These Hands"...1990 SSE BonnevilleLErocks Your Other Rides: Pics & Videos 6 03-20-2007 07:39 PM
ECC Stumble? opensourceguy 1987-1991 3 01-22-2007 06:33 PM
Bad stumble cadmanspd 1992-1999 1 10-28-2004 08:24 PM
HELP!!! Wants to stumble and die! (found the problem???) SSEi95 1992-1999 20 06-12-2004 02:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.