88 grand prix 2.8 won't accelerate - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-09-2014, 01:38 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
themechanic432 is on a distinguished road
Default 88 grand prix 2.8 won't accelerate

I have an 88 grand prix with a 2.8. It starts and idles fine, but as soon as I start to open the trottle the engine stumbles and dies. It will restart and idle fine. I have had the MAP, MASS, TPS sensors replaced. Fuel filter and fuel pump replaced. Converter has been flow checked and is OK. Any help on which direction to head next woulb be appreciated.
themechanic432 is offline   Reply With Quote
Old 04-09-2014, 05:08 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

ses? what is the exact number? did you replace those trying to fix this problem?
jwfirebird is offline   Reply With Quote
Old 04-10-2014, 11:09 PM   #3
Senior Member
Posts like a 4 Banger
 
Smoke's Avatar
 
Join Date: Feb 2012
Location: Texas
Posts: 103
Thanked 3 Times in 1 Post
Smoke is on a distinguished road
Default

Can't offer a thing regards that engine, but man, that problem is identical to the one I had with my ride. It was the ICM, at least with mine. Good luck, the guys here are fast with help.
Smoke is offline   Reply With Quote
Old 04-11-2014, 12:55 PM   #4
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

By process of elimination you are pretty much down an ignition coil or the ignition control module. Plugs and wires (which you did not mention) could give you a misfire, but your engine is stalling which leads me to believe that is not the problem.

Is the CEL lit?
2kg4u is offline   Reply With Quote
Old 04-14-2014, 03:48 PM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
themechanic432 is on a distinguished road
Default

This is my aunt,* vehicle. I did not replace them but she had a couple of local mechanics work on it and so far that is what they have replaced. At first the CEL was not on. Now it is flashing and the engine won't start at all. I scaned for codes and got a code 45. Fuel pressure is good. If this was a non ECM vehicle the symptoms say fuel problem. With all the parts that have been replaced , I am starting to think ignition module also.
themechanic432 is offline   Reply With Quote
Old 04-14-2014, 05:21 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

try unplugging the maf and see if it starts
jwfirebird is offline   Reply With Quote
Old 04-15-2014, 02:01 PM   #7
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
themechanic432 is on a distinguished road
Default

I will try that. I am going to work on it as I can this week. Trying to schedule it in. I don't have much free time except on weekends.
themechanic432 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 Bravada running sluggish when you accelerate Lynnlee GMC/Chevrolet Truck/SUV 18 02-23-2014 07:50 PM
6.2 diesel wont accelerate wwwhhhppp GMC/Chevrolet Truck/SUV 6 01-11-2012 07:57 PM
2001 grand prix blower moter won't turn off doodle4prez Pontiac 3 02-05-2011 03:03 PM
99 Grand Prix turns over, but won't start pontiac whoes Pontiac 2 12-18-2008 11:14 PM
BAM BAM BAM when I accelerate fast, sounds like roadhound General GM Chat 8 11-14-2008 04:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.