2004 Bonneville Stalls Intermittently - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-06-2016, 10:15 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 3
Thanked 0 Times in 0 Posts
MJC16 is on a distinguished road
Default 2004 Bonneville Stalls Intermittently

Good Evening GM family,

I have a quick question about an issue

My 2004 SE at only 90,500 miles has been stalling on me intermittently. It usually stalls when stopped at a red light and while driving anywhere from 30-60mph. I've had the CAM and Crankshaft Position Sensors replaced about a year and a half ago when I previously had this problem. Recently about a month ago my car began stall again. Turned out to be the MAF, I replaced it with an AC Delco MAF. It drove fine for a month and didn't stall until about a few weeks ago. When it began stalling it would start right up again. But last week it stalled on me and would not start up. When I had it towed to my mechanic it started right up at the shop. Each time the car has stalled, I have had the A/C on recirculate so I believe the stalling has something to do with something getting hot and shutting off power to the engine. I even brought this car to the dealer and they couldn't find out what'* wrong with it.

I have no idea of what it could be. I'm thinking it could be the ICM, which was already replaced at 62,000 miles. It could also be the Crankshaft position sensor failing again or even the PCM or ECM.

I'm thinking of getting a heatgun and letting the ICM heat up a little extra while running, to check if it stalls.

I forgot to add, the car is throwing no codes.

Was wondering if anyone else has had this problem and if anyone has any possible solution.

I would greatly appreciate any advice. I really like this car and do not want to get rid of it.


Thanks
MJC16 is offline   Reply With Quote
Old 07-07-2016, 04:40 AM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,571
Thanked 334 Times in 297 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Has the IAC & or throttle body been cleaned? (IAC controls the idle)
From a scanguage OBD2 reader, what is the idle rpm reading with AC on?
Does it suddenly drop a bit then stall?
Also add have you done tune up, new plugs, wires, fuel filter? Fuel pressure reading?
Also check fuel pressure regulator, disconnect vacuum line run car for 4 minutes with line plugged and off.
Look for any fuel dripping out of FPR.
Soft Ride is offline   Reply With Quote
The Following User Says Thank You to Soft Ride For This Useful Post:
MJC16 (07-07-2016)
Old 07-07-2016, 11:40 AM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,803
Thanked 219 Times in 180 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

When it stalls is it coughing and sputtering, or shutting down like someone flipped a switch. If it shuts down like flipping a switch it is likely a bad crank shaft position sensor ... one of the top 10 common failures with the 3.8 in the Bonneville.
2kg4u is offline   Reply With Quote
The Following 2 Users Say Thank You to 2kg4u For This Useful Post:
MJC16 (07-07-2016), WilliamE (07-08-2016)
Old 07-07-2016, 03:14 PM   #4
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 3
Thanked 0 Times in 0 Posts
MJC16 is on a distinguished road
Default

Thanks for the help! When the car stalls, it does shut down immediately like someone flipped a switch. Recently I cleaned the throttle body, but unsure about the IAC. The fuel filter was replaced about a year and a half ago and plugs and wires appear to be in good condition. Is there a possibility it could be the ICM, PCM, or ECM that is heating up and causing the vehicle to stall. I'm definitely going to look into the crank position sensor.
MJC16 is offline   Reply With Quote
Old 07-07-2016, 03:31 PM   #5
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 3
Thanked 0 Times in 0 Posts
MJC16 is on a distinguished road
Default

Also is it essential to replace the CAM sensor when replacing the Crankshaft position sensor. I know the two sensors work together.
MJC16 is offline   Reply With Quote
Old 07-07-2016, 07:24 PM   #6
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,044
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

No......
Tech II is offline   Reply With Quote
The Following User Says Thank You to Tech II For This Useful Post:
MJC16 (07-07-2016)
Old 07-07-2016, 07:28 PM   #7
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,044
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

I usually found, when a crank sensor was the problem, it wouldn't restart right away......

I am leaning towards the throttle body/IAC cleaning....also, check the vac line to the fuel pressure regulator for the presence of fuel......can also try tapping the MAF sensor when warm.....
Tech II is offline   Reply With Quote
The Following 3 Users Say Thank You to Tech II For This Useful Post:
MJC16 (07-07-2016), Soft Ride (07-08-2016), WilliamE (07-08-2016)
Old 07-24-2016, 02:48 AM   #8
Member
Posts like a V-Tak
 
Join Date: Dec 2015
Posts: 40
Thanks: 0
Thanked 12 Times in 11 Posts
grandpabuick will become famous soon enough
Default

I had a oldsmobile that would shut off while driving 50-70 mph like someone just flipped a switch. It was the screen on the fuel pump that had a dirty place on it that would suck up to the fuel pump and starve the engine.
grandpabuick is offline   Reply With Quote
Old 07-24-2016, 04:47 PM   #9
Senior Member
Posts like a Turbo
 
Join Date: Apr 2014
Posts: 417
Thanks: 0
Thanked 35 Times in 30 Posts
REGAL GUY has a spectacular aura aboutREGAL GUY has a spectacular aura about
Default

next time try unplugging the MAS and see if it starts back up
REGAL GUY is offline   Reply With Quote
Old 07-25-2016, 09:52 AM   #10
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,044
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

I think he meant MAF.....
Tech II is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 SLE stalls shifting into reverse jasenjo 2000-2005 11 06-05-2017 12:01 PM
2004 Grand Prix GT 3.8 L stalls simple0 Pontiac 1 05-21-2012 07:40 PM
92 Bonneville starts intermittently ott70 1992-1999 7 04-15-2012 01:39 PM
Car stalls intermittently when shifting from Drive to Revers Ponch 04 2000-2005 11 03-06-2008 09:21 AM
1990 Bonneville SE, intermittently stalls, runs rough BREWSKI1 1987-1991 11 02-13-2005 11:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:21 PM.