Trans am rough idle after changing water pump - Page 2 - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

Performance, Brainstorming & Tuning Talk about modifications, or anything else associated with performance enhancements. Have a new idea for performance/reliability? Post it here. No idea is stupid! (please use Detailing and Appearance for cosmetic ideas)

Trans am rough idle after changing water pump

Reply

 
 
 
Old 11-14-2013, 05:51 PM
  #11  
Junior Member
Thread Starter
 
Join Date: Nov 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
TheBeastlyTA is on a distinguished road
Default

Originally Posted by 75 racer View Post
Is this a V-8? If it is the distributer is behind the waterpump and you might of got some coolant on it. The LT1 motors didn't like moisture at all. It doesn't come as a seperate cap and rotor either you have to replace the dist assembly if it'* bad.
Yeah it'* a LT1, nothing got wet behind the pump.
TheBeastlyTA is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kimberly
Buick
24
06-17-2015 05:25 PM
cjpenny89
1992-1999
3
09-13-2006 12:15 PM
movintons
1992-1999
15
12-11-2004 04:26 PM
randman1
1992-1999
25
09-07-2004 09:20 PM
GTP2SSEi
General GM Chat
2
07-29-2003 01:46 PM


Thread Tools
Search this Thread
Quick Reply: Trans am rough idle after changing water pump


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.