Damien Runs but with issues..help needed - Page 7 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Performance, Brainstorming & Tuning Talk about modifications, or anything else associated with performance enhancements. Have a new idea for performance/reliability? Post it here. No idea is stupid! (please use Detailing and Appearance for cosmetic ideas)

Reply
 
 
 
Thread Tools Search this Thread
Old 03-16-2008, 06:52 PM   #61
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

Okay, I changed fuel rails, inspected all the orings, made sure they were OEM size, and they are. I used vasaline and such to help the injectors seat. However, they still wont.
Both centre injectors on each rail have blow by. When i rev it up, i can clearly see fuel spraying up around the oring and onto the injector(coming out of the head). It does not leak as bad as before, however this causes the car not to idle worth a ****.
What gives????
I know im doing everything correctly all the retainers are insalled correctly...
WTF
SSEimatt93 is offline   Reply With Quote
Old 03-16-2008, 06:58 PM   #62
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

is your rail bent?
harofreak00 is offline   Reply With Quote
Old 03-16-2008, 06:59 PM   #63
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

Both rails bent? I doubt it...this is the second rail ive tried.
SSEimatt93 is offline   Reply With Quote
Old 03-16-2008, 07:09 PM   #64
Senior Member
True Car Nut
 
Join Date: Dec 2005
Location: August 07 COTM....NEBF '06, CEBF '06 OHMM '06 ONBF '07 CEBF '07
Posts: 4,064
Thanks: 0
Thanked 0 Times in 0 Posts
PRD2BDF is on a distinguished road
Default

Could there be a gouge inside the bosses?
PRD2BDF is offline   Reply With Quote
Old 03-16-2008, 07:10 PM   #65
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

I guess anything is possible, but this time around i inspected them and made sure they were really cleaned out.
SSEimatt93 is offline   Reply With Quote
Old 03-16-2008, 07:16 PM   #66
Senior Member
True Car Nut
 
Join Date: Jun 2003
Location: Purgatory
Posts: 6,313
Thanks: 0
Thanked 0 Times in 0 Posts
PontiacDad is on a distinguished road
Default

These are the 42# injectors correct?
Did you try the stockers to see if the issue is there?
PontiacDad is offline   Reply With Quote
Old 03-16-2008, 07:20 PM   #67
Junior Member
 
Join Date: Jun 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
2000SilverBullet is on a distinguished road
Default

Can you push down on each individual injector to seat them. Don't just rely on pushing in on the ends.
2000SilverBullet is offline   Reply With Quote
Old 03-16-2008, 07:25 PM   #68
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

I know you already checked, but I'm just trying to help

Name:  DSC00451.jpg
Views: 0
Size:  60.4 KB
Name:  DSC00452.jpg
Views: 0
Size:  48.8 KB
harofreak00 is offline   Reply With Quote
Old 03-16-2008, 07:26 PM   #69
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

Ive got some messin around to do now. Im going to compare the orings once again to make damn sure they are the same as stock. Just those two centre injectors that arent going in enough to seal.
These are the 42.5s, yes. If I have to try the stock injectors I will just to rule out other things.
SSEimatt93 is offline   Reply With Quote
Old 03-26-2008, 01:37 AM   #70
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

The problem looks to be found.
And it was pretty obvious, but I was just to stupid to see..
Passing the information and what ive learned in this STICKY I made.
http://www.bonnevilleclub.com/forum/...052180#1052180
SSEimatt93 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buick 3800 barely runs on cold start...then runs fine racer42 General GM Chat 3 03-04-2011 01:13 AM
Damien's first Liquid Glass SSEimatt93 Your Ride: GM Pictures & Videos 11 08-07-2006 05:36 PM
Genuine SilverStar Turn signal bulbs from Damien driverjohn2005 Lounge 9 08-03-2006 03:29 AM
Damien SSEimatt93 Your Ride: GM Pictures & Videos 23 06-19-2006 09:34 PM
Damien and Red Deer SSEimatt93 Your Ride: GM Pictures & Videos 32 06-13-2006 01:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.