Alero tranny problems - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Oldsmobile When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-30-2014, 04:00 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
little white olds is on a distinguished road
Exclamation Alero tranny problems

Hello, new member in need of some help. My '04 Alero has about 60k on the ckock, the transmission fluid was changed at 50K and was in good condition. The transmission just stopped shifting and the speedo quit and check engine light came on. Disconnected battery for an hour or so, everything worked for a couple of miles then quit again.
Any advise would be greatly appriciated!


2004 Olds Alero 2.2L
2011 Chevy 1500 ext cab 6.2L
1989 Trans Am anniversary 3.8L TURBO

Last edited by little white olds; 12-30-2014 at 04:03 PM. Reason: missing info
little white olds is offline   Reply With Quote
Old 12-30-2014, 05:58 PM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Welcome to the forums Gary.
I would start by trying to get the car'* OBDII codes scanned, by using a good scanner.
I just want to clarify, when you say quits is it the transmission stops working and does the car continue to run or it stops running as well?
Soft Ride is offline   Reply With Quote
Old 12-30-2014, 08:30 PM   #3
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
little white olds is on a distinguished road
Default

Thanks for the quick reply. The car keeps running with no problems except the no shift and no speedo.
little white olds is offline   Reply With Quote
Old 12-30-2014, 09:11 PM   #4
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,143
Thanked 780 Times in 609 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

There is no dipstick....do you know the procedure for checking fluid level?
Tech II is offline   Reply With Quote
Old 12-30-2014, 09:20 PM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

sounds like the vss, should be a code for it if it is.
jwfirebird is offline   Reply With Quote
Old 12-31-2014, 09:12 AM   #6
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
little white olds is on a distinguished road
Default

Thanks, I will check into a code reader.
little white olds is offline   Reply With Quote
Old 01-03-2015, 09:49 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2014
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
little white olds is on a distinguished road
Default

Thank You Very Much! A $20 VSS fixed my problem. I was ready to change shift solenoids, Glad I found you guys first!
little white olds is offline   Reply With Quote
The Following User Says Thank You to little white olds For This Useful Post:
jwfirebird (01-04-2015)
Old 01-04-2015, 04:56 AM   #8
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Glad the speed sensor has you back on the road again!
Soft Ride is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
01 Oldsmobile Alero Fuel Mileage Problems michaelbiery Oldsmobile 34 04-14-2014 03:14 PM
In the Alero, has a Bonny in it, but more or less Alero. SSEimatt93 Your Other Rides: Pics & Videos 1 12-30-2007 08:43 PM
Problems, Problems, Problems... swartlkk 2000-2005 2 11-04-2005 08:57 PM
problems, problems, problems big_boss2010 1992-1999 15 04-25-2004 09:05 PM
Please read. Tranny problems with a newer tranny? bonnie94ssei General GM Chat 7 11-03-2003 02:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.