Yukon Cruise Control problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-21-2016, 07:52 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Gordoch is on a distinguished road
Default Yukon Cruise Control problem

I have a 2001 Yukon cruise control issue. The cruise control will not engage unless I plug in the trailer light adapter. With the adapter plugged in, the CC works fine until I turn on the turn signal which disengages the CC. Also, if the headlights are turned on, the CC disengages and will not reingage until the headlights are turned off. I do not have to have a trailer attached, just the trailer light adapter. It is the factory connection, no mods have been made. I also have replaced the brake switch.
Gordoch is offline   Reply With Quote
Old 07-21-2016, 11:40 AM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,052
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Was the trailer light adapter OEM, or aftermarket.....

If aftermarket, did problem occur after installation?
Tech II is online now   Reply With Quote
Old 07-21-2016, 12:26 PM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Gordoch is on a distinguished road
Default

The trailer set up is all factory. This just started occurring a short while ago. I have had the vehicle 5 years and it has worked fine up until now.
Gordoch is offline   Reply With Quote
Old 07-21-2016, 05:16 PM   #4
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,052
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Then it sounds like a backfeed problem, due to a bad connection or ground.....
Tech II is online now   Reply With Quote
Old 07-21-2016, 05:29 PM   #5
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Gordoch is on a distinguished road
Default

Any suggestions on how to chase it out?
Gordoch is offline   Reply With Quote
Old 07-21-2016, 09:46 PM   #6
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,052
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

You start with schematics......it will be fun trying to find one with the trailer adapter......

You may also have it scanned for codes, especially "B" and "U" codes, that might give you a starting point...
Tech II is online now   Reply With Quote
Old 07-22-2016, 07:54 AM   #7
Junior Member
Thread Starter
 
Join Date: Jul 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Gordoch is on a distinguished road
Default

Thanks, the search begins
Gordoch is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'00 Lesabre Cruise control problem dandyd Buick 24 09-09-2016 02:25 PM
Cruise control and lock up problem tigerwkb Pontiac 0 07-09-2016 10:12 PM
2008 Yukon tail light problem mxross240 GMC/Chevrolet Truck/SUV 2 04-16-2015 05:26 PM
2004 Yukon Service ride control zigger21 General GM Chat 1 07-13-2012 02:07 PM
Cruise Control Problem- NOT Vacuum or Switch Related....? Hans 1992-1999 3 12-14-2004 01:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:05 PM.