'93 G20 Van Start Issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-25-2013, 05:47 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2013
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
jwald is on a distinguished road
Default '93 G20 Van Start Issue

Hello. As stated, I have the G20 with a 5.0 and 135xxx. This truck has started quickly since the day I got it. The other day I ran some errands, stopping in a couple of places. At the last stop the truck wouldn't start; it just turned over. As I was low on fuel, not out, I thought that perhaps the truck being parked nose down on an incline might be the problem. I got it level, put in about 1/2 gal of gas, but still no luck. I suspected a fuel pump. In desperation, I pumped the crap out of the pedal while cranking and got a brief start, but not enough to run more than a couple of seconds. I had it towed home, let it sit for a couple days, and then went out to look it over. I hit the key and it started instantly, running great. Any ideas what might be going on? Thanks for the help.
jwald is offline   Reply With Quote
Old 04-25-2013, 07:30 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

alot of times on the tbi engines the icm in the dist goes like that bad when hot. you could see if it fires on start fluid when it quits if so its fuel not ign.
jwfirebird is offline   Reply With Quote
Old 05-11-2013, 07:05 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2013
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
jwald is on a distinguished road
Default

Quote:
Originally Posted by jwfirebird View Post
alot of times on the tbi engines the icm in the dist goes like that bad when hot. you could see if it fires on start fluid when it quits if so its fuel not ign.
2 days after I originally posted this, the truck started instantly. I let it run for a few minutes and shut it off. 2 days after that, and up to today, it won't start again. I finally got the chance to dig into the beast and took the dhouse and air cleaner off, and then tried to start with starter fluid. No start. I did see that my coil wire at the cap is ate up. I pulled the cap to check cap and rotor. The cap rotor contact pins where crusty, but I've seen worse, so I cleaned them off. I tried to remove the rotor, but it'* on tight. I'm afraid to put pressure from underneath for fear of snapping the outer ring around that gear mechanism in the dist. I will change the cap and rotor if I can get them off. I get fire from the coil to the cap. Next step is to see if I get fire to the plugs. Am I on the right track? Any ideas that might speed the process? Thanks.
jwald is offline   Reply With Quote
Old 05-12-2013, 11:55 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if it wont run on fluid its a spark issue, so seems like you are on the right track, new cap and rotor are cheap enough on a tbi that i wouldnt screw with cleaning it
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Safari van no start Marshal GMC/Chevrolet Truck/SUV 11 06-02-2014 08:52 AM
1993 g20 Sport Van will not start, whitenite General GM Chat 7 11-04-2013 10:09 PM
Chevrolet Conversion van/no start. Mike Chevrolet 1 01-03-2013 09:53 PM
help me diagnos the van issue (FIXED!) harofreak00 Lounge 30 12-05-2006 08:19 PM
Which van? driverjohn2005 Lounge 16 02-03-2003 06:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.