03 Denali yukon xl 1500 6.0l throttle position sensor location - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-09-2016, 07:31 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default 03 Denali yukon xl 1500 6.0l throttle position sensor location

I was reading on where the throttle position sensor wad located and this part they seem to show right near the throttle body where you have to move the alternator

They said this one fits my motor but I couldn't find where it'* located at


and this one is part of the throttle body


Would this one be just my throttle position sensor or do I have 2.

Anyone know
Attached Thumbnails
03 Denali yukon xl 1500 6.0l throttle position sensor location-80-main_95ec2010bb2b9dfcf4375c0dd5a0867388da21e7.jpeg   03 Denali yukon xl 1500 6.0l throttle position sensor location-80-shopping_f95fea51fd78ceeb8267901155aac8b5f4ca6f29.jpeg  
denaliman03 is offline   Reply With Quote
Old 01-09-2016, 10:26 PM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,647
Thanked 999 Times in 775 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Depends, do you have have DBW(drive by wire) or throttle cable?
Mike is offline   Reply With Quote
Old 01-10-2016, 02:01 AM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Looks like I have the drive by wire so it would be the part in picture 2 then . How u no when they go bad or start to go bad
denaliman03 is offline   Reply With Quote
Old 01-10-2016, 02:37 AM   #4
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Sometimes but not always a TPS will throw a Service /Engine light on with a code.
General symptoms, delayed acceleration,surging speed on it'* own or idle problems/stalling.
What symptoms are you experiencing that makes you believe it is the TPS ? Any codes?
Soft Ride is offline   Reply With Quote
Old 01-10-2016, 08:57 AM   #5
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,647
Thanked 999 Times in 775 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

If he is DBW, his TPS is in the accelerator itself.
Mike is offline   Reply With Quote
The Following User Says Thank You to Mike For This Useful Post:
Soft Ride (01-10-2016)
Old 01-10-2016, 11:00 AM   #6
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Engine will stall after hard acceleration
Bucking and Jerking/Hesitation while Accelerating
Transmission not shifting correctly/Difficulties in changing gears
denaliman03 is offline   Reply With Quote
Old 01-10-2016, 11:00 AM   #7
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Hesitate in power
denaliman03 is offline   Reply With Quote
Old 01-10-2016, 11:06 AM   #8
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,647
Thanked 999 Times in 775 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

If you can find a scantool that can do live data, monitor the TPS sensor as you are stepping on the accelerator. You should see the throttle go from 0-100% with no gaps or hiccups.
Mike is offline   Reply With Quote
The Following User Says Thank You to Mike For This Useful Post:
Soft Ride (01-10-2016)
Old 01-11-2016, 11:32 AM   #9
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Just take it to the dealer then
denaliman03 is offline   Reply With Quote
The Following User Says Thank You to denaliman03 For This Useful Post:
Soft Ride (01-11-2016)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A Bad TPS sensor or something else (Throttle position sensor) DeathDealer General GM Chat 17 03-27-2017 10:30 PM
2003 Sierra 1500 Denali - Air bag sensors - Advice needed Pat from Quebec GMC/Chevrolet Truck/SUV 5 08-18-2015 10:19 PM
2002 Yukon Denali XL Electrical Disconnect johnnyidaho14 GMC/Chevrolet Truck/SUV 6 05-24-2015 12:31 AM
1999 Yukon Denali PCM pinout NEEDED richard_lyew Chevrolet 1 05-11-2011 05:02 PM
05 Yukon Denali XL replace 1 tire or 4? boomersantos General GM Chat 4 03-14-2011 12:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.