Quits while driving - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-21-2008, 02:53 AM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Phoenix, AZ
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
dougd7 is on a distinguished road
Default Quits while driving

'97 SE. Car will just shut off while driving. Sometimes stumbles on acceleration, too. Just finished with a Crank Shaft Sensor Code/P0336. Cleaned connector going into ignition module and lost code. Had an exposed wire at the connector probably due to losing my supercharger belt because of a bad pulley.

Could I just have a bad Crank Shaft Sensor behind the damper that needs to be replaced?

Thought I had solved this problem by cleaning up the connector, but just came back tonight. Haven't run a system check yet, but my gut is telling me I'm going to have to replace the sensor.

Also have a P0420 Catalyst Trouble Code, below threshold.

Looking for answers.
dougd7 is offline   Reply With Quote
Old 10-21-2008, 07:53 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Hi Doug..I did a few bouts with a similar issue and it turned up as a crank sensor. Although it sounds like you found a bad wire as well.

If you want to ensure this one is taken care of, I'd replace that wiring harness and the crank sensor at the same time and then it should be good. The harness plugs in next to the ICM on the front of the fuel rail and only runs to the ICM, crank sensor and cam sensor. It is the same harness on all Series 2 motors.

If you don't have good junkyards around or would rather..I believe there'* only 4-5 laying around at my place. $5-7 would cover the shipping and packing. I don't need this many and would gladly send you one.
BillBoost37 is offline   Reply With Quote
Old 10-22-2008, 06:11 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Phoenix, AZ
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
dougd7 is on a distinguished road
Default

Thanks, BillBoost37! I know that'* probably coming up in my near future to replace the wire harness, crank sensor and connector. It would probably cost me more to go "pull a part" here in Phoenix. Absolutely would love to have one in good shape if you've got some laying around. If you don't mind, let me know an address to send you $10.00 or so for the shipping. You're in CT, so don't know what shipping costs would amount to.

Again, thanks for the reply and the info. At this point, I haven't had it quit while running in the past couple of days and it is running better, but you know how it goes. Need to go ahead and replace it for a little peace of mind.

Doug D.
dougd7 is offline   Reply With Quote
Old 10-22-2008, 09:12 PM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Phoenix huh? Toss a pm to PDXGTP he and another buddy also live at the equator like you do.

Please toss me your address in a private message and I can get the actual costs for you. Shouldn't be more than $5
BillBoost37 is offline   Reply With Quote
Old 10-23-2008, 02:30 AM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Phoenix, AZ
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
dougd7 is on a distinguished road
Default

Thanks BillBoost37. Sent you my address in a private message. Hope it gets to you O.K. if I did everything correctly. Certainly appreciate your help. Thanks again!

Doug D.
dougd7 is offline   Reply With Quote
Old 10-23-2008, 07:10 AM   #6
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Got it and replied. Working on connecting you with a couple guys local to you in case this problem continues.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
driving lights off while driving 99bonne Audio (and aftermarket electronics) 2 01-25-2008 02:30 AM
car dies while driving then wont start for a while..? help 88bonnsse 1987-1991 23 05-29-2007 10:30 PM
'92 SSE --- engine quits running intermittently. BusMaster007 1992-1999 19 01-24-2007 01:44 PM
When to call it quits tallbump General GM Chat 32 11-02-2006 08:17 AM
Engine Quits BikerBob 1992-1999 9 05-23-2005 04:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:59 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.