BAD smell after hard braking - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-15-2005, 01:11 AM   #1
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Oct 2002
Posts: 11,307
Thanks: 0
Thanked 0 Times in 0 Posts
bonnie94ssei is on a distinguished road
Default BAD smell after hard braking

Over the past week and a half to two weeks I noticed that every once in a while my ABS light would come on when I started the car, other times it wouldn't. Last night I was driving the car and I was driving it pretty rough. By 'rough' I mean hard acceleration a few times in a row. (This car shifts really high, almost to redline from 1st to 2nd, and 2nd to 3rd....it'* fun to drive, I can't help it sometimes )

Anyway, I applied the brakes pretty hard just to see how they functioned, since my ABS light was on again. Well after all the driving and then applying the brakes, I started to smell a nasty burnt smell. I had no idea what it was, but I KNEW something was wrong. I stopped the car and opened the hood and I could see a little bit of smoke coming from underneath the engine, over by the driver'* side strut tower and around the ABS module...that general area. I first thought it smelled like coolant burning...and I thought a gasket blew...but I found that it wasn't that. But it smelled horrible.

I drove it again, not accelerating hard, but I did brake from about 70mph to 0 pretty quickly, and I could smell it again. I am starting to think it'* brake fluid burning somehow. I know somethings up with my brakes anyway because today the ABS light came on again, and even the parking brake light came on and stayed on even when the p-brake was disengaged. I smelled what I did the night before, but later in the day it was gone.

The car runs fine, but the ABS light comes on once in a while, and I notice it takes more pressure to stop the car. I also hear a bit of a rattle sound maybe every couple days when I brake...the sound comes from the pedal itself, as if something'* loose. My dad and I changed the brakes probably 3 1/2-4 weeks ago tops and there were no problems until the past week an a half. Hope I explained everything well.

Anyone have any ideas as to what'* going on? Thanks a ton!

-Pete
bonnie94ssei is offline   Reply With Quote
Old 02-15-2005, 01:35 AM   #2
Senior Member
Expert Gearhead
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

If your cars ABS system is anything like mine Pete, you have a brake line that leads from your master cylinder to the ABS controller. If the line is leaking then brake fluid is dripping onto a hot transmission casing. Check to see if there is a braided section on your brake line.

If something is not right with the system or the ABS controller is not receiving brake fluid pressure, it may throw and ABS light. I highly doubt its the ETCBM, which is good.

Just an idea bro...hopefully its just a line. 11 years out of a braided line (if that is the case) is not to bad. Have a look for leaks and watch the master cylinder for brake fluid loss.
Jim W is offline   Reply With Quote
Old 02-15-2005, 01:47 AM   #3
Senior Member
Posts like a Camaro
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default

Mine made a horrible smell too before i replaced the MC
looong4 is offline   Reply With Quote
Old 02-15-2005, 09:23 AM   #4
Junior Member
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

when you changed the brakes you didn't let the brake caliper hang from the brake line did you? It could be possible that the hose was older, dried out, and cracked so now it'* spraying fluid onto the rotors (hot) when you brake. OR like Jim said, you could have a bad brake line near the ABS module that is worn out and sprays fluid when applying the brakes hard. Either one could cause your braking problems. The parking brake light is coming on because you're probably low on fluid, that is the most common cause for that light coming on.
Custom88 is offline   Reply With Quote
Old 02-15-2005, 11:52 AM   #5
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

Did you check your fluid levels in the resivoir? Did the ABS come on when this happened?

Maybe Try Pulling your ABS fuse to disable the system, and brake hard and see what happens.
BonneMeMN is offline   Reply With Quote
Old 02-15-2005, 12:00 PM   #6
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Lakeville, MN
Posts: 4,328
Thanks: 0
Thanked 1 Time in 1 Post
fantastic88 is on a distinguished road
Default

If the car had cheap brake pads put on they will stink. My car had new brakes installed when I bought it and they really stunk for a couple weeks. Now they are half worn.
fantastic88 is offline   Reply With Quote
Old 02-15-2005, 04:20 PM   #7
Senior Member
Certified Car Nut
Thread Starter
 
Join Date: Oct 2002
Posts: 11,307
Thanks: 0
Thanked 0 Times in 0 Posts
bonnie94ssei is on a distinguished road
Default

I'm guessing it must be a leak too so I'll just double check to see if a line is cracked. I had thought that it was dripping on the tranny case too since the smoke was coming from that general area. The fluid level looks good, but I do know that when my dad changed the front pads (he improvises sometimes, does things his way, plus it was freezing out so he was in a hurry) fluid started leaking when he was pushing the caliper pistons in. I could see it from under the car.

I drove to work today. I had no ABS light this time. I'll try pulling the fuse too. Thanks guys, I'll keep you posted.
bonnie94ssei is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
bad engine mounts= shaking when braking?? jonniewalker Pontiac Bonneville 4 02-22-2014 09:43 AM
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Hard to steer while turning left while braking erin0525 2000-2005 9 12-11-2007 09:31 PM
Awkward smell from exhaust after hard run Bonneville92V688 1992-1999 6 06-15-2007 05:21 PM
Help! Sudden stalling during hard braking. Puddy46 1992-1999 6 01-04-2005 05:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.