Rear driver side turn signal doesn't work - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-01-2012, 05:17 PM   #11
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i dont have drawings now. im going to have to look later. you would think if you can hear the thing clicking it shouldnt be the switch. does the dash indicator light up solid or do nothing at all? your brake lights and turn signals separate or together(same bulb)?
jwfirebird is offline   Reply With Quote
Old 03-01-2012, 08:50 PM   #12
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default



if your front one comes on you can test where the yellow wires separate at the i/p fuse block and see if you have voltage there if not something is up with the module or switch. if you have voltage there you need to trace it toward the rear lights and see where you loose it
Attached Thumbnails
Rear driver side turn signal doesn't work-01bonnieleftturn.jpg  
jwfirebird is offline   Reply With Quote
Old 03-01-2012, 10:38 PM   #13
Senior Member
Posts like a Turbo
Thread Starter
 
03SSEISUPERCHARGED's Avatar
 
Join Date: Jan 2008
Location: Sheboygan-Right Next to Road America
Posts: 437
Thanked 3 Times in 2 Posts
03SSEISUPERCHARGED is on a distinguished road
Default

Quote:
Originally Posted by jwfirebird View Post
i dont have drawings now. im going to have to look later. you would think if you can hear the thing clicking it shouldnt be the switch. does the dash indicator light up solid or do nothing at all? your brake lights and turn signals separate or together(same bulb)?
The dash indicator doesn't even turn on, not when you click the left turn switch or even when you hit the flashers. The front turn signal in the headlight housing is on like normal but doesn't flash on and off like it should. On the 00+ they are separate not all the same its an amber bulb.
03SSEISUPERCHARGED is offline   Reply With Quote
Old 03-01-2012, 10:46 PM   #14
Senior Member
Posts like a Turbo
Thread Starter
 
03SSEISUPERCHARGED's Avatar
 
Join Date: Jan 2008
Location: Sheboygan-Right Next to Road America
Posts: 437
Thanked 3 Times in 2 Posts
03SSEISUPERCHARGED is on a distinguished road
Default

Quote:
Originally Posted by jwfirebird View Post


if your front one comes on you can test where the yellow wires separate at the i/p fuse block and see if you have voltage there if not something is up with the module or switch. if you have voltage there you need to trace it toward the rear lights and see where you loose it
To be honest not a clue what the diagram is but my guess is that the amber lights(turn signal) on the left front are on like normal but don't blink. The only goes on when it blinks and since it doesn't blink i got nothing. If the switch supplies the power to that rear light to make it blink and the switch is broke that would explain no power. I know when I had my aurora car I had kinda the same problem but that switch was shorting out causing the headlights to flicker on and off when the car wasn't running. My gf works at the local ford dealership and she asked the two head mechanics and they both said if its not a fuse its the switch.
03SSEISUPERCHARGED is offline   Reply With Quote
Old 03-02-2012, 08:37 AM   #15
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

you cant trust dealer parts replacers. especially if they arent even the same brand car that your working on. if you have power to the front light that meens you have power good till they split apart. but you are dealing with a fasher module which complicates things sometimes. it needs to have the proper load resistance to blink so the simplified version is its very likely its something where or after they split,thats why i posted the drawing so you could check for voltage from there and see where you lose it.
jwfirebird is offline   Reply With Quote
Old 03-15-2012, 02:12 PM   #16
Senior Member
Posts like a Turbo
Thread Starter
 
03SSEISUPERCHARGED's Avatar
 
Join Date: Jan 2008
Location: Sheboygan-Right Next to Road America
Posts: 437
Thanked 3 Times in 2 Posts
03SSEISUPERCHARGED is on a distinguished road
Default

Well replaced the switch today with a used one from saw gunner. I went from having clicking when turning the turn signal on both left and right to no turn signal on the right no clicking on the right. I have clicking on the left but no turn signal. I do get a right turn signal when I hit the hazards but still no left ones. Could it be the relay or is there a module down there? Id start stripping wires and do some testing but on a scale of 1-10 im a 1 on electrical work.
03SSEISUPERCHARGED is offline   Reply With Quote
Old 03-22-2012, 11:03 PM   #17
Senior Member
Posts like a Turbo
Thread Starter
 
03SSEISUPERCHARGED's Avatar
 
Join Date: Jan 2008
Location: Sheboygan-Right Next to Road America
Posts: 437
Thanked 3 Times in 2 Posts
03SSEISUPERCHARGED is on a distinguished road
Default

Well to the shop it goes.
03SSEISUPERCHARGED is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
air blows cold on passenger side, driver side outside air. eltatertoto Buick 16 05-09-2014 02:07 AM
Driver side window doesn't work 94-bonni ggenovez 1992-1999 10 05-20-2011 01:59 PM
Need help ASAP. Driver side turn signal stays on crazyrealtor 2000-2005 3 04-10-2009 10:26 PM
need a new rear turn signal receptacle weathdl Everything Electrical & Electronic 11 05-10-2007 09:57 PM
turn signal arm is loose and high beams wont turn on!! artofwar215 1992-1999 2 03-16-2007 09:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.