Random Engine Stumble, NO CEL - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-11-2014, 10:08 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Apr 2005
Posts: 243
Thanks: 0
Thanked 3 Times in 3 Posts
dandyd is on a distinguished road
Default Random Engine Stumble, NO CEL

I just purchased a 2000 Impala LS (3800 Series II). Upon driving it much today thru my routine daily driving 3 (THREE) times accelerating from a light the engine coughed or stumbled making me think the engine was about to die, it did not, kicked and went on just fine. Engine idles beautifully, I've cleaned the TB and IAC. No CEL displays and most of the time runs beautifully but in nearly 70 miles of city driving today it worked great except those 3 times the engine randomly stumbled, kicked, coughed and then went on fine....... Ideas anyone??
dandyd is offline   Reply With Quote
Old 09-12-2014, 08:20 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

how old are the plugs and wires? check fuel pressure? i would check the tps with a meter and see if the output is unstable.


https://www.gmforum.com/trouble-shoo...sensor-279319/

Last edited by jwfirebird; 09-12-2014 at 08:22 AM.
jwfirebird is offline   Reply With Quote
Old 09-12-2014, 08:31 AM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Apr 2005
Posts: 243
Thanks: 0
Thanked 3 Times in 3 Posts
dandyd is on a distinguished road
Default

Just bought the car, so I don't know how old plugs and wires are. IF there was a TPS would there not be a consistent problem? I drove it 50 miles yesterday and it only did it 3 times....all the other times I performed flawlessly?
dandyd is offline   Reply With Quote
Old 09-12-2014, 09:50 AM   #4
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,142
Thanked 778 Times in 608 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

There are tranny codes that will set and not put the CE light on...have it scanned.....

Private party, used car lot, or dealership? Any warranty?
Tech II is offline   Reply With Quote
Old 09-12-2014, 02:57 PM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

seems to me like something is fading out, isnt quite bad enough to set a light yet. like tps or maf. you can clean the maf see what it looks like. they are both alot easier to test if you have a live data scanner hooked up when it does it you can see what flakes out
jwfirebird is offline   Reply With Quote
Old 09-16-2014, 02:11 PM   #6
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Apr 2005
Posts: 243
Thanks: 0
Thanked 3 Times in 3 Posts
dandyd is on a distinguished road
Default

Finally showed a "Pending" (not yet lit) Check Engine code of P0502--- Intermittent Vehicle Speed Sensor..... in researching this it stated, "symptoms of a faulty speed sensor may also result symptoms of other common components such as a defective coil pack or bad throttle position sensor."............ gonna replace this tonight and we'll see what happens.
dandyd is offline   Reply With Quote
Old 09-16-2014, 06:50 PM   #7
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,636
Thanked 990 Times in 769 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Replace what tonight?
Mike is offline   Reply With Quote
Old 09-17-2014, 06:38 AM   #8
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

They are talking about replacing the Vehicle Speed Sensor.
WilliamE is offline   Reply With Quote
Old 09-17-2014, 07:40 AM   #9
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,636
Thanked 990 Times in 769 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Ok, the way he was talking, it sounded like he was going to replace the coil pack or something.
Mike is offline   Reply With Quote
Old 09-17-2014, 03:06 PM   #10
LA1
Member
Posts like a V-Tak
 
LA1's Avatar
 
Join Date: May 2013
Location: east coast
Posts: 99
Thanked 7 Times in 6 Posts
LA1 is on a distinguished road
Default

So you got the pending code for the TPS ? Could also be the IAC. Could also be your fuel filter. Those are guesses After the car stalls will it start right up? What does your coolant look like...... any oil in the coolant , any coolant in the oil? I know u said you replaced the upper intake gasket. Did you replace the throttle body to manifold gasket. I have heard of people using 2 gaskets. Also the EGR port can eventually burn a hole in the manifold.

Last edited by LA1; 09-17-2014 at 03:07 PM.
LA1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'92 LeSabre engine stumble on turns LeSabre L27 Buick 9 05-13-2012 03:57 PM
Engine Stumble? 90LE General GM Chat 4 08-09-2010 11:31 PM
CEL on CEL off and now back on again.. bandit01 1992-1999 1 06-15-2007 08:37 AM
Check engine light eliminates off idle stumble. 57lxi 1992-1999 7 05-17-2007 07:45 AM
HELP!!! Wants to stumble and die! (found the problem???) SSEi95 1992-1999 20 06-12-2004 02:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:37 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.