Need help impala ls 2000 no crank no start no nothing - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-03-2016, 05:13 PM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Dec 2013
Location: right now venezuela
Posts: 176
Thanked 9 Times in 8 Posts
danihound will become famous soon enough
Default Need help impala ls 2000 no crank no start no nothing

Hi.

right now my impala does not want to crank or anything, you insert the key turn it to on and nothing happens.

i dont know if its the passlock but no security light comes on after you try to start it, just the red battery light.

what should i do?

i scanned the car and it has no error code either.
danihound is offline   Reply With Quote
Old 05-03-2016, 10:56 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,150
Thanked 785 Times in 614 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Well, your SECURITY LIGHT should be on, check engine light should be on, BAT light should be on, with the key in the "on" position....

What did you scan the car with? A codes reader? Cheap scan tool? All either can, read is "P" codes......you need to be a able to read "B" or body codes and "U" or communication codes.....

When you turn the key on, the SECURITY LIGHT should be on....it stays on until the vehicle starts and runs...

You can check the crank relay in the relay center under the hood.....have someone turn the key to the crank position, and feel the relay to see if it clicks....if it doesn't, then try swapping the relay......if it still doesn't click, then The PCM may not be grounding it, because it is not getting a crank signal from the BCM, which gets it from the PassLock sensor....

More often than not, if it is a PassLock problem, a code B2958 or B2960 will be set.....

If the relay is clicking, then check the purple wire to the starter solenoid, with a test light....it should light when the key is in the crank position.....if it does, you need a starter....
Tech II is offline   Reply With Quote
The Following 2 Users Say Thank You to Tech II For This Useful Post:
danihound (05-04-2016), WilliamE (05-04-2016)
Old 05-04-2016, 12:58 PM   #3
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Dec 2013
Location: right now venezuela
Posts: 176
Thanked 9 Times in 8 Posts
danihound will become famous soon enough
Default

Update

thanks Tech II, the car now start, this is what happened:

i called an ex chevrolet mechanic to get help, he checked the fuses, and the battery,and he just sat in the car pressed the brake really hard and turned the key, and the fcking car started right away.

he then turned the engine off, and then on again no problem, but he did say that i should check the starter, it probably have a bad cable, or the bad injector, so i would go to check those ( i do have a bad injecto and i already have the replacement).

at least the car runs now, i do have to press the gas pedal sometimes cause it dosnt stay on some times.
danihound is offline   Reply With Quote
Old 05-04-2016, 02:58 PM   #4
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Replace the bad injector, and it would not hurt to clean the MAF when you get a chance, unless you have cleaned it recently.
WilliamE is offline   Reply With Quote
The Following User Says Thank You to WilliamE For This Useful Post:
danihound (05-04-2016)
Old 05-06-2016, 05:27 PM   #5
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Dec 2013
Location: right now venezuela
Posts: 176
Thanked 9 Times in 8 Posts
danihound will become famous soon enough
Default

problem solved as stated above
danihound is offline   Reply With Quote
The Following User Says Thank You to danihound For This Useful Post:
WilliamE (05-06-2016)
Old 05-06-2016, 06:25 PM   #6
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Thanks for letting us know what the problem was, and that you got it fixed.
WilliamE is offline   Reply With Quote
The Following User Says Thank You to WilliamE For This Useful Post:
danihound (05-06-2016)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Impala LS 2000 No Start Condition danihound Chevrolet 65 10-24-2014 09:23 PM
2000 corvette with ls3 no crank need help!! dustybegood Chevrolet 5 08-04-2014 01:44 PM
2000 Impala no start caused by short! divac Chevrolet 9 05-23-2013 08:46 AM
Crank no start- 2000 Bonneville slick94prix 2000-2005 11 07-08-2009 09:51 AM
no start, no crank condition when attempting to start my 93 mybonnilaysundertheoceam Introductions for new members 2 01-09-2005 05:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.