need a hand on a 2004 8.1L spark knock - Page 10 - GM Forum - Buick, Cadillac, Olds, GMC & Pontiac chat

Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

need a hand on a 2004 8.1L spark knock

Old 12-09-2018, 08:45 PM
  #91  
Senior Member


Posts like a Corvette
 
Join Date: Feb 2015
Location: Earth
Posts: 1,305
Thanked 190 Times in 170 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

Sounds like progress. I don't think it should idle at 800RPM warmed up though. 650-700 would be better.
CathedralCub is offline  
Old 12-14-2018, 05:37 PM
  #92  
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2018
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
terry735001 is on a distinguished road
Default

so have a small update . its looks like your feelings about the PCM where right
after moving alot of things back to stock in the PCM its starting to run alot better
going to have to do some fine tuning but its coming and the misfires are going away
here is what 1 of the guys had to say about what my tune / pcm was doing

Originally Posted by 10_SS View Post
I looked through just a couple tables in your tune, there are so many different tables compared to the stock file. For example your WOT Main Spark table is asking for 30 degrees of Timing! WOW. Stock is around 15-18 degrees.

I would suggest taking all of the tables in mine, and pasting to yours just see how it fires up. I would guess your getting so much knock retard that your running mostly in the Low Octane timing table, if that is even enabled still, then the Low Octane table only has 2 degrees less. Not Good. Seeing that much timing in the High Octane table tells me the other tuner didn't really know what he was doing or maybe it'* still setup for Propane, I don't know. The changes made seem like "In Theory more timing and less fuel will increase MPG", but in reality you can't run like that. Those values look like something you would run on 115 Octane.

Your Spark Dwell Settings are also 20-30% different.

All of your Idle/RPM/Proportional settings are much different also, like 500% different.

Desired IAC Area Max, huge difference. 2000 vs 226.

MAF Airflow table isnt that far off, a good sign that the overall setup is the same.

Injector Flow Rate vs Manifold pressure also very close to the same but I don't see Injector Flow Rate vs Fuel Pressure.. strange.

Fuel Prime Pulses are 0'd on your tune.

02 sensor Rich/Lean values are lower on yours.


LTFT Min Learn is 200% on mine, 6% on yours.

Closed loop Proportional is Disabled on mine with 0 in my tables, yours enabled and set to 14g/sec.

There'* a lot changed, I would try to revert back to stock, sounds to me like Fuel Correction is limited and not showing you the real problems your having.

A big problem I see is with Open Loop F/A vs Coolant Temp vs MAP. Yours is basically set to 1.00, which isnt adding any fuel cold. Set this back to stock from my table.

PE Enrichment, your tune has that running very lean, so very lean with 30deg of timing, not good. Put back to stock (mine).

Transient Fueling is disabled in yours.

Missfire detection, this is disabled around 400-500rpm on yours, likely why your not getting codes.

So many things that arent good in yours, I would take most of my tables and import into yours. You should see big changes.

terry735001 is offline  
Old 12-16-2018, 12:55 AM
  #93  
Senior Member


Posts like a Corvette
 
Join Date: Feb 2015
Location: Earth
Posts: 1,305
Thanked 190 Times in 170 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

Wow.

Yeah based on those numbers I can see why it has problems.
CathedralCub is offline  
Old 01-06-2019, 02:20 PM
  #94  
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2018
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
terry735001 is on a distinguished road
Default

UPDATE

it did take me some time to get the nerve up to take it for a test drive and really to save up the money for a tow bill if any thing should go wrong

i did a test drive with it up in to town and it seems good .

i can tell it had a hot rod tune in it over just a stock tune . so i lost a good bet of power . i have to keep my foot in it more . or that'* the way it feels any ways
still get from 0 to 60 fast when i want it to but i guess it does not feel right as its not the same tune so it feels off to me

when i got into town and turned it off for a few mins it did not want to start up as fast . it had to roll over alot and all most start then died and did this a few times like it had air in the fuel line .
not sure if this is the tune or some thing else

still sounds like it has a misfire but the app shows its all good so i know why . i am thinking its the way i remade my exhaust pipes . the old system has folds / bumps in the pipe where it was bent to make the tune and helped with the sound
the new pipes does not have this and the pipe is just 2 feet long before its in the muffler and out the back so i feel i am getting alot of funny sounds as i have a really high flow muffler

the RPM seems low again as when i was setting at a red light when the air pump comes on it can pull 2 HP so that would pull the RPM down in the 590s . i would like to see more 650

but i am back down to 1 big thing thats never been there before and this is a loud vacuum sound when accelerating or as the TB opens like its not getting the air it needs
this has been there from the start of all this so its not the tune

i am going to get a new TB and take it all back apart for the 9th time relook at all my intake pipe and see if i can find any thing wrong
terry735001 is offline  
Old 01-06-2019, 09:56 PM
  #95  
Senior Member


Posts like a Corvette
 
Join Date: Feb 2015
Location: Earth
Posts: 1,305
Thanked 190 Times in 170 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

Sounds like progress.

For what it'* worth, I had a friend'* Tahoe returned to factory tune after complaints of lots of weird things that it did. It acted like it was strung out on cocaine. Returned to stock it felt more sluggish since I was used to its crazy programming. I got used to it quickly because it felt like my Yukon when it got out of rehab. I figured out the throttle tip-in was a big part of my perception. The crazy load made it jump pretty hard when you start into the throttle, and the normal load was more linear.

For the starting issue, I'd check fuel pressure when you turn the ignition on.
CathedralCub is offline  
Old 01-07-2019, 05:47 PM
  #96  
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2018
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
terry735001 is on a distinguished road
Default

humm to me its seems the other way now .

as i am slow into the throttle i seem to have a dead zone like you see in EVs in eco mode then about 20% throttle its hot out of the gate
not sure if this is stock to save gas or a Small truck tune over a C7500 tune

old tune was more linear and soft but would dump HP if i needed it .
EVERY thing on the motor side of the PCM is stock file from a 2005 8.1l all5spd stock silverado
BUT the TCM tune is not the same . but i like how mine is so i left it alone
what i am afraid of is the 2005 silverado and 2004 C7500 GVWR are not set the same so i am sure the TBC / Electronic throttle control (ETC) are not the same part numbers

but i am going to take it camping this week and over the weekend and see how it does . i need some miles on the motor as its still just 40esh miles on it from the shop so it needs some run time
i well have a better report soon on hows its running
terry735001 is offline  
Old 01-09-2019, 12:57 AM
  #97  
Senior Member


Posts like a Corvette
 
Join Date: Feb 2015
Location: Earth
Posts: 1,305
Thanked 190 Times in 170 Posts
CathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to beholdCathedralCub is a splendid one to behold
Default

Engine stopped, ignition on, watch the throttle position as you slowly press the throttle from 0% to 100% and back again. See if you see that dead spot.
CathedralCub is offline  
Old 01-10-2019, 06:22 PM
  #98  
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2018
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
terry735001 is on a distinguished road
Default

i well do that this weekend . my friend is off work and i am going to take the RV on a 100 mile road trip

after thinking about the loud vacuum sound when accelerating or as the throttle position opens like its not getting the air it needs
i think its how the intake for the air pump is piped into the system

the airpump is a 14 CFM pump so i made it pull its clean air from the intake air from the air filter box .... this is some thing seen alot on big trucks
when the pump is in "load" it pulls this air from behind the filter its self in the boxs its self . not the motors intake 4inc pinp
when the pump is in "unload" i think its back pulling vacuum though the cylinder head of the air pump all the way back to the air dryer

this sound was never there before intell all this started so in a way i dont think its that but i well do some testing and look into it
terry735001 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
L27Buick
1992-1999
7
09-17-2004 04:23 PM
Spiral
1992-1999
5
05-25-2004 09:57 AM
Spiral
1992-1999
5
05-23-2004 10:08 PM
streetracer
Performance, Brainstorming & Tuning
1
08-18-2003 02:08 PM
Tamara
1992-1999
10
01-31-2003 05:26 PM


Thread Tools
Search this Thread
Quick Reply: need a hand on a 2004 8.1L spark knock


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.