Chevy Impala speakers no longer working...??? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-24-2016, 09:17 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2015
Posts: 71
Thanked 3 Times in 3 Posts
Skyward is on a distinguished road
Default Chevy Impala speakers no longer working...???

I got an 06 Impala that speakers no longer working on. No warning noises, seat belt noise, radio, etc...I took radio fuse out a couple of months back to use for a fuse that burned out since I rarely use the radio. I finally got around to putting in a new fuse and when I did, NOTHING! Radio works, CD player etc..but no noise! Any tips on locating the issue?
Skyward is offline   Reply With Quote
Old 09-26-2016, 01:35 PM   #2
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2015
Posts: 71
Thanked 3 Times in 3 Posts
Skyward is on a distinguished road
Default

Bump..?
Skyward is offline   Reply With Quote
Old 09-27-2016, 04:11 PM   #3
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,044
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

So how do you know the radio/cd works if there is no sound?

I assume you mean the radio head lights up when turned on, but nothing comes from the speakers, even if a cd is put in....

Does this have an amplifier? There is a 20 amp radio fuse....there is a 25 amp fuse for the amplifier.....check that fuse....
Tech II is offline   Reply With Quote
Old 09-28-2016, 03:29 PM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2015
Posts: 71
Thanked 3 Times in 3 Posts
Skyward is on a distinguished road
Default

Quote:
Originally Posted by Tech II View Post
So how do you know the radio/cd works if there is no sound?

I assume you mean the radio head lights up when turned on, but nothing comes from the speakers, even if a cd is put in....

Does this have an amplifier? There is a 20 amp radio fuse....there is a 25 amp fuse for the amplifier.....check that fuse....

Interesting, I had no idea there was an AMP fuse as it is not listed on the back of the fuse cover. You don't happen to have a diagram of the fuses do you?
Skyward is offline   Reply With Quote
Old 09-28-2016, 09:13 PM   #5
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,044
Thanked 750 Times in 585 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Not all radios have amps....just wondered if yours did, and if you checked the fuse....

Your radio fuse is located in the underhood fuse block....if you have an amp fuse, it will be located in the I/P fuse block....
Tech II is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 Chevrolet Impala Radio Problem - door speakers sometimes work GrandPixel Audio (and aftermarket electronics) 8 09-04-2012 02:49 PM
Speedometer needle and gas gauge no longer working theozara General GM Chat 3 09-15-2010 06:08 PM
windows no longer working :( 2000binbc 2000-2005 8 05-17-2010 01:40 PM
Anyone have an Impala or Impala service manual 92BonneSE Lounge 7 05-28-2007 12:53 AM
1989 Bonneville LE Truck Button in Glove no longer working Punkrulz 1987-1991 3 05-08-2004 12:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:10 PM.