2004 Chevy malibu 3.5 LX9 engine dies while driving - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-05-2012, 10:11 AM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
icemanthe1 is on a distinguished road
Default 2004 Chevy malibu 3.5 LX9 engine dies while driving

My daughter has owned since new it has 115,000 it will drive just fine no misses until all of a sudden it will stumble and the tac will drop and then die. The code it is giving over and over is PO335, I installed a new one and after that did not fix it I also did a ckp re-learn. I am thinking that the PCM has a failure inside of it that is causing this, and yes I know those things are the last thing to replace. I have tried all things cleaned grounds make sure they are tight, checked all sensors. I have replaced the crank position sensor, the cam sensor, the map, maf and the coil pack.Now when it dies in order to restart I must clear all codes, where before it would re-start very easy.
icemanthe1 is offline   Reply With Quote
Old 10-05-2012, 02:32 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

did you take resistance measurements to the pcm from the connector? try shaking the wire while doing this to see if the pins or an intermittent open. make sure the wires arent shorted or rubbing on the chassis anywhere or shorted to another wire. can you see the reluctor ring is it turning? any other codes?
jwfirebird is offline   Reply With Quote
Old 10-06-2012, 10:34 AM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
icemanthe1 is on a distinguished road
Default

yes I checked all connections for ground and power, no you cannnot see the reluctor ring the ckp is on the lower back side of the engine. It has thrown several other codes but none are consistant like the po335. It gave a po520 once, egr codes, cam sensor code,evap code. Talking to a person who repairs and also sells auto pcm' is saying that this type of pcm has been a problem. He has sold and many of this type because of a processer problem, and almost all of the buyer feed back he has recieved has been the new pcm fixed the problems. So I ordered a new one from him will get it monday, if that is not the problem then it leaves me with a fault of the reluctor ring.
icemanthe1 is offline   Reply With Quote
Old 10-06-2012, 01:26 PM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

post what the fix is, havent heard of many like that
jwfirebird is offline   Reply With Quote
Old 10-06-2012, 02:14 PM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
icemanthe1 is on a distinguished road
Default

yes I will and this has been driving me crazy I replaced the ckp twice used a bright light and checked all wires to it with a madnifing glass. As well as all connectors I am sure it is the pcm will post either way.
icemanthe1 is offline   Reply With Quote
Old 10-09-2012, 03:08 PM   #6
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
icemanthe1 is on a distinguished road
Default

I replaced the pcm it drove fine for about 15 miles, then while stopped at a traffic light the engine fluttered a couple of times the died. It would not re-start for about 2 minutes, and with in about a mile it died again. Again it took about 2 minutes before it would re-start it is giving the PO335 code again same as before.
icemanthe1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 Lesabre starts,dies-starts,dies munkee Buick 4 07-28-2008 07:53 AM
driving lights off while driving 99bonne Audio (and aftermarket electronics) 2 01-25-2008 02:30 AM
car dies while driving. and car jolts foward? PROBLEM FIXED. 88bonnsse 1992-1999 56 07-11-2007 01:16 AM
car dies while driving then wont start for a while..? help 88bonnsse 1987-1991 23 05-29-2007 10:30 PM
95'SE Starts,Dies,Starts,Dies... kc7oer 1992-1999 13 04-13-2006 10:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:14 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.