1999 4.3 only runs only with maf disconnected - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-14-2013, 09:33 AM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
200VEGAS is on a distinguished road
Question 1999 4.3 only runs only with maf disconnected

my sons truck will barely accelerate and wont get on the freeway at all with the maf plugged in. it shows low volt at all 4 o2 sensors we pulled the o2'* ahead of cat and didnt help. he accidently unplugged maf and it runs ok.not perfect, but preety goog. so he is driving it like that. we replaced the maf and it didnt change anything so we returned it and put the old one back on, but it is not plugged in. any ideas... fuel rail is at 35lbs and fuel filter is new
200VEGAS is offline   Reply With Quote
Old 02-14-2013, 10:31 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i think you should have 50+ psi for poppets, maybe pump going out

shouldnt even run. you try a different gauge?
jwfirebird is offline   Reply With Quote
Old 02-14-2013, 11:13 AM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
200VEGAS is on a distinguished road
Default he converted it to the newer style

spyder upgrade injector style and we think its regulator is set at like 35
200VEGAS is offline   Reply With Quote
Old 02-14-2013, 11:14 AM   #4
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
200VEGAS is on a distinguished road
Default

we tried several gauges, yes
200VEGAS is offline   Reply With Quote
Old 02-14-2013, 11:36 AM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

wont run on 35, 50 to 55 will run 58+ will make it run properly.
jwfirebird is offline   Reply With Quote
Old 02-14-2013, 01:58 PM   #6
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
200VEGAS is on a distinguished road
Default

even though it is mpfi and not cpfi. i thought i read somewhere the pressure regulator runs at 35 on the mpfi conversion.
200VEGAS is offline   Reply With Quote
Old 02-14-2013, 02:46 PM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

no ive done the conversion, its exactly the same. is this a full size? shouldnt matter 35 is way to low. but ive got new delphi pump, filter, and the new delphi mpfi and mine is 58psi engine off and runs at mid 60'* engine on
jwfirebird is offline   Reply With Quote
Old 02-14-2013, 04:16 PM   #8
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
200VEGAS is on a distinguished road
Default

ok, we will replace pump. thank you very much. i also called delphi and they said 60-68
200VEGAS is offline   Reply With Quote
Old 02-14-2013, 05:02 PM   #9
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

vortec engine is really pressure critical. when i did my pump a month or tow later it started acting weird again, the pressure was going down to 53. it ended up being the filter i had on it must have gotten trash in it when i dropped the tank, so something to watch out for
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel Pressure Regulator Vac Hose Disconnected, Car Still Runs slyjay Pontiac 6 08-07-2015 01:41 PM
99 Buick Regal 3.8l only runs with MAF unplugged nick52405 Buick 10 05-12-2011 11:45 PM
Buick 3800 barely runs on cold start...then runs fine racer42 General GM Chat 3 03-04-2011 01:13 AM
If Car runs better with MAF unplugged can I? trixster68 1992-1999 5 08-03-2009 10:57 AM
Driving with MAF disconnected HurstGN 2000-2005 3 11-07-2007 04:23 PM


Tags
runs good without maf

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:49 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.