1995 chevy 4.3 tbi bad misfire at idle help!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-11-2014, 10:20 PM   #1
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
chevyman828 is on a distinguished road
Default 1995 chevy 4.3 tbi bad misfire at idle help!!

hey, I have a 1995 chevy 1500 with a 4.3 tbi engine, the truck picked up a terrible misfire at idle it does it in park and drive it almost feels like a dead cylinder truck lurches real bad,etc. but it will rev up fine and runs fine once you get past 1000rpms but it will sputter slightly when you get on the gas from a stop light then it clears out and runs fine,i had previously thought the miss was from the catalaytic converter that was on the truck that was completely clogged but once I replaced it the miss is still there, I have preformed several tests, I tested the tps which passed , put a new iac on no change, tested the map sensor which worked perfect, new spark plugs, tested each cylinder for spark and they all are fine, all the injectors appear to be spraying correct, I cleaned the egr which seemed to be fine, the cat was clogged for a good while it may have knocked the 02 sensor out which I haven't changed but there is no cel on the dash if some one can help me figure this out it would be a big help! thanks
chevyman828 is offline   Reply With Quote
Old 05-12-2014, 01:39 AM   #2
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

I would start looking for a vacuum leak. Our 95 Blazer acted just like that when the EGR stuck open, but it also set a SES light. It was fun though, at some points the truck would quit surging and idle like it was cammed, shaking the whole truck in the process.

Also check the MAP sensor to make sure it'* working right too.
rjolly87 is offline   Reply With Quote
Old 05-12-2014, 08:41 AM   #3
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

You mentioned you replaced the plugs, but what about the wires?

Have you had it scanned for any codes? Just because the light isn't on, doesn't mean a code is pending or there is a non-lighting code present.
Mike is offline   Reply With Quote
Old 05-12-2014, 03:20 PM   #4
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
chevyman828 is on a distinguished road
Default

I have checked for vacumn leaks and found none taken propane and sprayed it around all the lines and manifold no rpm change it a 1995 obdii or obd1 ? How do I pull codes
chevyman828 is offline   Reply With Quote
Old 05-12-2014, 03:21 PM   #5
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
chevyman828 is on a distinguished road
Default

I have not changed wires but the show strong spark with a tester
chevyman828 is offline   Reply With Quote
Old 05-12-2014, 03:24 PM   #6
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

How old are they?
Mike is offline   Reply With Quote
Old 05-12-2014, 03:50 PM   #7
Senior Member
Posts like a 4 Banger
 
ahicks66's Avatar
 
Join Date: Oct 2012
Location: Salem, CT
Posts: 114
Thanks: 0
Thanked 7 Times in 5 Posts
ahicks66 is on a distinguished road
Default

Crazy idea, I know... Not really sure how your '95 is setup, but I had a '91 4.3 that had the same symptoms, and I discovered it was the injector harness. In '91s, there are two fuel injectors - one for each bank. I had an intermittent problem where one injector would lose connection entirely, and I would be driving - barely - on 3 cylinders. I had to pull over, pop off the air cleaner, and wiggle the plug. Idle would immediately smooth out and be running like a champ.

Again, I'm not sure when they made changes in the 4.3s, but it'* something you can quickly check if you have a similar setup. I've also heard of the later 4.3s having issues with the "injector spider," which I assume is the same type of deal across more than two injectors.
ahicks66 is offline   Reply With Quote
Old 05-12-2014, 04:46 PM   #8
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
chevyman828 is on a distinguished road
Default

the wires im not sure how old they are they haven't changed them since I got the truck years ago, I just figured they were good because I put an inline spark tester (the one that hooks between the wire and the plug) on it and it all of them sparked good, I really donnt think its an injector issue, mine does have the two injectors one for each bank and I watch them while its running and they seem to spay great, thanks I will deffinently check the wiring though.
chevyman828 is offline   Reply With Quote
Old 05-12-2014, 11:42 PM   #9
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,148
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

Tried a cylinder balance test to see which cylinder is misfiring?
Tech II is offline   Reply With Quote
Old 05-13-2014, 03:17 PM   #10
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
chevyman828 is on a distinguished road
Default

I have not I'm going to do a compression test and see what I come up with
chevyman828 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 GMC K1500 TBI 350CI, Fuel delivery D Ryan GMC/Chevrolet Truck/SUV 11 07-02-2011 04:18 PM
Why would someone block the EGR? 5.7L TBI stegarsla Cadillac 10 05-13-2011 05:25 PM
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Chevy 305 TBI For Sale Lowrider0308 Lounge 1 09-30-2007 01:53 AM
'87 TBI 305 help.... Damemorder Lounge 20 08-26-2004 01:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.