04 impala issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-13-2012, 03:56 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
dtutsgolf is on a distinguished road
Default 04 impala issue

Hello fellas!

I have an 04 impala that has 77K on it and yesterday it started having a problem. It seems to lose torque (by that i mean that it makes NONE going up hill) until it gets to 4th gear and even then it still doesn't pull as hard as it should. When the car is first turned on it is fine until it hits a certain point (it varies) and then it'* like the chain falling off on a bicycle, has a hell of a time making torque and it misses unless the slightest touch on the accelerator is used (the tach needle bounces all over the place). any ideas??
dtutsgolf is offline   Reply With Quote
Old 03-13-2012, 04:21 PM   #2
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Is the CEL lit? Is it flashing?
2kg4u is offline   Reply With Quote
Old 03-15-2012, 02:41 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
dtutsgolf is on a distinguished road
Default

no check engine light on, and when attached to a reader it spits out no codes
dtutsgolf is offline   Reply With Quote
Old 03-15-2012, 05:50 PM   #4
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I'm thinking MAF sensor, but that seems to quick and sudden if its really dirty. Have you changed/added anything recently? Like added a air filter?
Mike is offline   Reply With Quote
Old 03-15-2012, 07:20 PM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

do you mean the trans is slipping? the engine revs and you dont go anywhere? the tach follows the engine or bounces independent of the engine?
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
impala 1 big issue apu Chevrolet 7 12-14-2012 10:25 PM
01 impala engine swap. now have issue jim85 General GM Chat 12 04-02-2012 11:32 AM
2005 Chevy Impala Intermittent crank issue chevyboys Chevrolet 6 02-26-2012 06:58 PM
Airbag issue with 2003 Impala jhazard112 Chevrolet 0 11-18-2010 02:16 AM
Anyone have an Impala or Impala service manual 92BonneSE Lounge 7 05-28-2007 01:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.