Urgent - truck issue that can't be found - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-21-2012, 03:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
NANCY is on a distinguished road
Default Urgent - truck issue that can't be found

I'm having trouble with my Avalanche and it has happened 3 times. Driving to work I stepped on the brake at the intersection and it felt hard then I turned onto the main road and it would barely move but I made it to the garage station. They were not there then and it had a bad smell so I left it. I dropped my things off at the office got back in to the truck and it was drove fine and they couldn't find out what is wrong. Can someone help me? Ever since I owned this truck it would make a sound and more so in the cold weather and from the day I got it someone asked me if I had a bad muffler. I'm more concerned about my brakes on the truck and need to tell the service man where to look. URGENT.
NANCY is offline   Reply With Quote
Old 03-21-2012, 04:01 PM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,643
Thanked 997 Times in 774 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Are you saying at the first stop, your brake pedal felt normal(firm) then you tried to move and the vehicle seemed to struggle moving?

Seems like you have a brake hung up based on the smell and it struggling. Are your parking/emergency brakes still applied part way by any chance?
Mike is offline   Reply With Quote
Old 03-21-2012, 04:16 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
NANCY is on a distinguished road
Default

Yes, the first stop going down our private driveway it felt hard. Then the truck would hardly drive down the road and the middle gauge I believe 6 RMP (almost to the end of it) was showing. I could smell it from the hood dropping off my office "stuff" and then drove it over and it was 2 hours later before they came to work at the garage. When they test drove it no problem and this happened before. They keep stating they can't find anything wrong. I'll bring gloves to have in my truck in case this happens again and I will put my hands on the metal frame on my tire to see if it gets hot. I'm going to call them shortly to see if they still haven't found the issue. Where should they look and thank you for taking the time to help me. Nancy
NANCY is offline   Reply With Quote
Old 03-21-2012, 04:19 PM   #4
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
NANCY is on a distinguished road
Default

Yes, the first stop going down our private driveway it felt hard. Then the truck would hardly drive down the road and the middle gauge I believe 6 RMP (almost to the end of it) was showing. I could smell it from the hood dropping off my office "stuff" and then drove it over and it was 2 hours later before they came to work at the garage. When they test drove it no problem and this happened before. They keep stating they can't find anything wrong. I'll bring gloves to have in my truck in case this happens again and I will put my hands on the metal frame on my tire to see if it gets hot. I'm going to call them shortly to see if they still haven't found the issue. Where should they look and thank you for taking the time to help me. Nancy
NANCY is offline   Reply With Quote
Old 03-22-2012, 07:27 AM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

there are sliders that the brake pads move in and out on if these arent replaced or cleaned and lubed when you do a brake job or just after time sometimes they build up with crap and hang up and if its before 04 could have it in both the front and back
jwfirebird is offline   Reply With Quote
Old 03-22-2012, 08:15 AM   #6
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
NANCY is on a distinguished road
Default

I just took it back this morning and they are going to look at the brakes. I only have about 5700 miles on my 2011 Avalanche and never had brake work done. Yesterday when it happened my private road was muddy from the frost and it was pulling the truck back and forth and when I braked at the end of my road, this is when it happened.
NANCY is offline   Reply With Quote
Old 03-22-2012, 06:29 PM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

too new to be what i was thinking. maybe some mud or something is stuck in there.
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Urgent trans issue! bo58gardner 1992-1999 48 01-21-2011 01:05 PM
I might've Found a Beater Truck. xDRx Lounge 10 11-22-2007 12:40 PM
URGENT URGENT Cookseytonyc 1992-1999 6 01-08-2006 11:40 AM
News video of truck/car/truck crash. Amazing. randman1 Lounge 8 04-05-2005 05:46 PM
URGENT!!! How can I disable the SES light? bambam 1992-1999 11 07-17-2004 11:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.