2007 Escalade Transmission Problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Cadillac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-23-2011, 12:31 AM   #1
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default 2007 Escalade Transmission Problem

Last few weeks i noticed my transmission been acting up.

Today it got much worse, i was leave the house i throw it into Drive i push the gas and the car wouldn't move, as if its in neutral.
About 5 seconds later it jumps as if someone rear ended me. SES light comes on.
I tried scanning it but my HP scanner wont connect to it, so i have no DTC codes at the moment. The second the SES light came on the car wont go into manual mode and its taking off very slowly, as if I'm driving true standard and trying to take off using 4th gear, so gutless.
I started looking at fuses and what not, i removed the Transmission Control Module fuse while the car is running nothing happened.
I removed it while the car was off, and restart and the check engine is gone.
I throw it into drive, nothing happens, i shift down to M-1 its fine, go into M-2 the engine drops maybe 100rpm and SES comes on again.
The car is so gutless, i can barely drive it. and theres no caddy dealer in town.

what to do what to do...
SAMzGXP is offline   Reply With Quote
Old 05-23-2011, 12:37 AM   #2
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

My intrepid has the lurching issue..I beleive it to be a tcc lockup solenoid oor some sort of solenoid..Looks like your getting it towed/doing it yourself/or taking it to a local shop and paying outta pocket
sseidriver97 is offline   Reply With Quote
Old 05-23-2011, 12:43 AM   #3
-- SITE DONATOR --
True Car Nut
 
ymmot04's Avatar
 
Join Date: May 2009
Posts: 4,638
Thanked 5 Times in 4 Posts
ymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of light
Default

Have you checked the fluid levels? How does the color of the trans fluid look?
ymmot04 is offline   Reply With Quote
Old 05-23-2011, 01:49 AM   #4
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

Dakota, I had a similar issue with my GTP years ago, and it was the TCC solenoid, it used to burn the TCC fuse, i replace it and used to be good for a while till i got it fixed. But i just couldnt find any fuses that were burnt, unless the solenoid itself is out.

Tom, The fluid level is fine, but i remember when i was having my last oil change they said my tranny cooler lines are leaking, yet i check the fluid and its fine at the HOT level. didnt check it when its cold. as for the color its till good
SAMzGXP is offline   Reply With Quote
Old 05-23-2011, 08:11 AM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if your lines are leaking you wont have the right pressure. i was surprised at how little it takes to make the trans act funny, my yukon was doing the same thing after i did a bunch of things on the trans and all it was was about a 1/4 to an 1/8 inch down from the hot line.
jwfirebird is offline   Reply With Quote
Old 05-23-2011, 07:27 PM   #6
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

Any idea what fluid to use?
SAMzGXP is offline   Reply With Quote
Old 05-23-2011, 08:29 PM   #7
Senior Member
Posts like a Supercharger
 
flyballdog's Avatar
 
Join Date: Aug 2010
Location: Tweed Ontario Canada
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
flyballdog is on a distinguished road
Default Trans Fluid Type

It should state on the dipstick or in owners manual what type of fluid to use.
flyballdog is offline   Reply With Quote
Old 05-23-2011, 08:50 PM   #8
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

yeah but i was more looking for an answer on the go
SAMzGXP is offline   Reply With Quote
Old 05-24-2011, 12:26 AM   #9
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

When it takes off in gear, is it like loaded up, or slipping? If it'* loaded up, it sounds like the torque converter is locked up. could be a bad TCC solenoid.
Danthurs is offline   Reply With Quote
Old 05-24-2011, 01:12 AM   #10
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

Quote:
Originally Posted by SAMzGXP View Post
yeah but i was more looking for an answer on the go
Your answer on the go (and based on your model year, probably the correct one) is DEXRON-VI. It'* backwards-compatible with almost all GM-made transmissions.

Please, please verify before you start pouring it in. Using -VI in a transmission made for -III will void your wallet; using -III in a transmission made for -VI will void your transmission'* warranty (or worse).
SignOfZeta is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2010 Escalade Leaking Transmission BroCo Cadillac 6 01-09-2014 12:16 AM
FS: HID and NON HID Projector headlamps, 2007+ Escalade t... slick94prix Lounge 1 08-03-2007 06:46 PM
New Escalade dbeast420 Lounge 3 04-19-2007 10:21 AM
Wicked A$$ Escalade Bonneville92V688 Your Other Rides: Pics & Videos 10 03-06-2007 12:34 AM
new escalade sqela Lounge 2 11-19-2005 01:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.