Power Lock - acting strange - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-08-2015, 12:56 AM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: May 2014
Posts: 163
Thanked 6 Times in 5 Posts
eb-86 is on a distinguished road
Default Power Lock - acting strange

Hello ,
I want to describe something about my power lock in 2001 Lesabre .
I have a buttons on the two front doors , driver and passenger side .
when I push the button "Unlock" the doors are open but when I Push on "Lock" it not react , in both of them .
and now is the strange thing ... when I drive sometimes (specially when i turn RIGHT) the "Lock" work by itself ...

What could be the problem ? someone have the electric circuit of power lock system ?
eb-86 is offline   Reply With Quote
Old 02-08-2015, 11:50 AM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,149
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

So, the locks will not lock manually when pressing the button....

Do you have an RKE fob......will it lock with the key fob?

What about when you put the car in Drive, do the doors automatically lock?

As you can see, this is not a simple system like on other cars.....the door modules communicate via serial data......the easiest way to diagnose this is with a Tech II scan tool.....good possibility a "B" code is set.....sounds like a wiring problem to me......I doubt both switches went bad at the same time.....each door has it'* own module, and I doubt they failed at the same time.....so I think it is a wiring problem, rather than hardware.....was looking for something common to both sides, but since your power windows and mirrors don't seem to have a problem, it looks like the power and grounds to the modules are ok......

Like I said, a scan tool would show if the door module was receiving a signal from the door lock switch and if it was passing that signal on, via serial data, to the other door modules....but even I don't have a Tech II....











Attached Thumbnails
Power Lock - acting strange-0996b43f80244a78.gif   Power Lock - acting strange-0996b43f80244a77.gif   Power Lock - acting strange-0996b43f802449c7.gif   Power Lock - acting strange-0996b43f802449c8.gif   Power Lock - acting strange-0996b43f80244a72.gif  

Power Lock - acting strange-0996b43f80244a73.gif  
Tech II is offline   Reply With Quote
The Following 3 Users Say Thank You to Tech II For This Useful Post:
eb-86 (02-09-2015), Soft Ride (02-09-2015), WilliamE (02-08-2015)
Old 02-09-2015, 01:07 AM   #3
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: May 2014
Posts: 163
Thanked 6 Times in 5 Posts
eb-86 is on a distinguished road
Default

The doors locks from the remote and when i put the car in Drive .
the only thing that don't work is the Lock button . (the Unlock works fine) .
can you direct me where to looking for ?
eb-86 is offline   Reply With Quote
Old 02-09-2015, 02:59 AM   #4
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Why do I have the feeling it may be the switch itself? Obviously removing the door panel for further testing would be best but...
Why not try spraying some electrical contact cleaner down in ( lock side) of the switch itself...
Water can get in there when window is down quite often, may be corroded.
Would the ground bus have anything to do with this?

Last edited by Soft Ride; 02-09-2015 at 03:03 AM. Reason: Add ground bus?
Soft Ride is offline   Reply With Quote
Old 02-09-2015, 08:33 AM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i would guess something with the switch assembly. if it works with the remote most everything else has to work
jwfirebird is offline   Reply With Quote
Old 02-09-2015, 11:50 AM   #6
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,149
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

But he says BOTH switches do the same thing.......if this happened at the SAME TIME, I doubt it is the switches failing at the same time......now if it happened where one failed, and then over a period of time, the other failed, then it could be both switches.....

Very easy to check the switch....we know the unlock works.....remove the switch, and ground the "C" terminal of either switch and see if the locks, lock...
Tech II is offline   Reply With Quote
Old 02-09-2015, 02:32 PM   #7
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: May 2014
Posts: 163
Thanked 6 Times in 5 Posts
eb-86 is on a distinguished road
Default

I'll cheak it.
like I said ,sometime when i turn the steering wheel RIGHT the "Lock" suddenly works .
something very strange ... maybe i have a ghost in my car ?????
eb-86 is offline   Reply With Quote
Old 02-09-2015, 04:04 PM   #8
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Ghost Locks Ha ha, Ya never know, stranger things have happened...
You could drive to the local cemetery after midnight, open all the doors, and ask Casper nicely, to go visit some of his other friends for a while....
Soft Ride is offline   Reply With Quote
Old 02-10-2015, 02:58 AM   #9
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: May 2014
Posts: 163
Thanked 6 Times in 5 Posts
eb-86 is on a distinguished road
Default

Quote:
Originally Posted by Soft Ride View Post
Ghost Locks Ha ha, Ya never know, stranger things have happened...
You could drive to the local cemetery after midnight, open all the doors, and ask Casper nicely, to go visit some of his other friends for a while....
Haaaa ....
eb-86 is offline   Reply With Quote
Old 02-12-2015, 01:15 AM   #10
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: May 2014
Posts: 163
Thanked 6 Times in 5 Posts
eb-86 is on a distinguished road
Default

Someone know where to start ?
where the device located ?
eb-86 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bonne acting strange 99BonneSLE 1992-1999 14 07-30-2017 06:46 PM
Transmission acting strange under any acceleration from 0 radomirthegreat 1992-1999 19 04-27-2008 09:26 PM
Turn signal acting strange on my 95 Bonneville whitecrystal1 Everything Electrical & Electronic 6 06-10-2007 09:08 PM
Strange power door lock problem Andrew97Cobra Oldsmobile 3 01-10-2006 05:48 PM
car acting strange L27Buick Lounge 3 08-22-2003 10:19 AM


Tags
buick lesabre, electrical issue, power locks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.