?? Help...missing the heat shield over the temp sensor..... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-06-2014, 06:20 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Dec 2006
Posts: 471
Thanks: 0
Thanked 1 Time in 1 Post
goldfinger22 is on a distinguished road
Default ?? Help...missing the heat shield over the temp sensor.....

Got my 2000 Lesabre back today...new UIM, new LIM gaskets, coolant elbows, coolant flush, tstat, oil chg...but the heat covering pc that was over the temp sensor is junk...where can I get another of is it even needed ????
goldfinger22 is offline   Reply With Quote
Old 03-06-2014, 09:21 PM   #2
Senior Member

Posts like a Camaro
 
Join Date: Aug 2013
Location: Northern California
Posts: 1,014
Thanked 164 Times in 130 Posts
75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold
Default

I've thrown a few away in my career and never had one come back.
75 racer is offline   Reply With Quote
Old 03-06-2014, 09:58 PM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Dec 2006
Posts: 471
Thanks: 0
Thanked 1 Time in 1 Post
goldfinger22 is on a distinguished road
Default

???? youve thrown a few what away, the heat covers ??? And what never came back, the car ? So are you saying I dont need it ?
goldfinger22 is offline   Reply With Quote
Old 03-06-2014, 11:56 PM   #4
Senior Member

Posts like a Camaro
 
Join Date: Aug 2013
Location: Northern California
Posts: 1,014
Thanked 164 Times in 130 Posts
75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold75 racer is a splendid one to behold
Default

Yes working at the dealer I did quite a few intake jobs on the 3.8 and that silver heat cover that goes around the coolant temp sensor either ripped or fell off and I put it back together without it and never had a customer come back with a issue. The early 3.8 series 2 didn't even come with them. I think they started using them in 01 or 02.
75 racer is offline   Reply With Quote
The Following User Says Thank You to 75 racer For This Useful Post:
Soft Ride (03-07-2014)
Old 03-07-2014, 07:10 AM   #5
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,647
Thanked 998 Times in 774 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I removed mine YEARS ago because it was already falling off. No issues yet.
Mike is online now   Reply With Quote
Old 03-07-2014, 08:14 PM   #6
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Dec 2006
Posts: 471
Thanks: 0
Thanked 1 Time in 1 Post
goldfinger22 is on a distinguished road
Default

I keep smelling coolant since he did the job...None is missing and I dont see any leaks anywhere....think its just from flushing the cooling the system and having coolant get all over the engine ?? I dont see aleak or drip on the elbows,hoses,waterpump etc...seems all dry and again the resivor is at the same level ???
goldfinger22 is offline   Reply With Quote
Old 03-07-2014, 08:51 PM   #7
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,647
Thanked 998 Times in 774 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

LOL, no worries if its not leaking anywhere and your levels are fine. It'* just like you suspect. Your actually smelling it cook off the engine. If you still smell it a week later, then maybe its time to start looking again.
Mike is online now   Reply With Quote
The Following User Says Thank You to Mike For This Useful Post:
Soft Ride (03-08-2014)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Runs hot - no heat - then temp drops and heat works?? atp 2000-2005 15 12-16-2009 07:46 AM
Missing Splash Shield...This is odd. Barry General GM Chat 11 10-08-2007 07:14 PM
Making a heat shield for the K&N cone Blk_Bonneville Performance, Brainstorming & Tuning 2 06-22-2003 01:25 AM
Intake Heat Shield 2000SilverBullet Performance, Brainstorming & Tuning 16 02-09-2003 03:15 AM
Exhaust heat shield? Dr. Moomoo 1992-1999 2 12-31-1969 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.