1994 park av 3.8 stock. egr code and high idle...... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-12-2011, 04:59 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
meomike2000 is on a distinguished road
Question 1994 park av 3.8 stock. egr code and high idle......

have a egr code for P1406...

replaced egr with new and check to make sure egr ports were not clogged....

hooked up my snap on scanner,
run for about 2 mins at idle,
then i can accel to above 1500 rpm and the egr will show to be at about 18% with a desired at 0%....

even upon returning to idle it will show to be around 18% with a desired of 0%..

the egr voltage will go up from .66 when the engine is accel above 1500, but will return to .66 upon engine returning to idle but the egr will show to be at around 18%......

also after it sets and idles this way for a couple mins it will start to accel on its own, the iac steps go to 195 and the engine revs above 1700. maf show to go from < 6 gps to > 18 gps ( iac open at 195).....

all other data appears normal...

any help or ideas would be very helpful...

thanks in advance,

mike
meomike2000 is offline   Reply With Quote
Old 06-12-2011, 05:13 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Take off th eEGR tube that gose from the EGR valve to the LIM. Hold it up to the light, it may be cracked.
Danthurs is offline   Reply With Quote
Old 06-12-2011, 06:18 PM   #3
Junior Member
Thread Starter
 
Join Date: Jun 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
meomike2000 is on a distinguished road
Default

the tube has no leaks that i can find. i think the problem is in the electrical somewhere, not a mechanical problem.....

I would think that a cracked tube or a vacuum leak would explain a high idle all the time. In this case it is more random, not all the time.
meomike2000 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Bonneville misfire and high idle baseballride351 Everything Electrical & Electronic 2 04-06-2009 02:53 PM
1994 Olds LSS stalling randomly, P1406 code - !!Fixed!! EGR KneeHowMa 1992-1999 13 12-18-2006 06:31 PM
1994 Park Ave - rough idle caddymac Buick 13 08-13-2006 05:41 AM
EGR low flow. Replaced EGR, still getting code 1997_LeSabre 1992-1999 8 04-20-2005 10:06 AM
high idle in park and while driving HELP! italianstallion84 1992-1999 14 01-05-2005 11:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.