1994 Bonneville misfire and high idle - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-05-2009, 02:18 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
baseballride351 is on a distinguished road
Angry 1994 Bonneville misfire and high idle

I'm trying to figure out if anyone else is having the same problem as I am. My 3800 is misfiring on the 2 and 5 coil. I replaced it and still the same. I'm thinking CMU? This morning the car started and slowly idled up all the way to 4000 rpm. I had to jump in skivies and go shut it off. Then it started fine and idle correctly. Sometimes the car idles bad due to the misfire and stalls out. Any ideas? I had a 3800 in a lesabre that went 254,000 miles and still ran great. I never did anything to that car. I'm at 136,000 with this one and am puzzled.
baseballride351 is offline   Reply With Quote
Old 04-05-2009, 03:27 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Test all your coils and plug wires. Inspect the plugs and post pistures of them if you can.
Danthurs is offline   Reply With Quote
Old 04-06-2009, 02:53 PM   #3
Junior Member
Posts like a V-Tak
 
Join Date: Mar 2009
Location: Just outside of NYC
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
thefloyd is on a distinguished road
Default

I'd seen the creeping/high idle on my 1994 when the throttle position sensor went bad. Check/disconnect your TPS and see if you still get the weird idle. You might be chasing two separate problems (idle weirdness and misfire) or the PCM getting bad data from the TPS could be causing issues.
thefloyd is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Idle Problem first, now high idle 98 Buick LeSabre Kimberly Buick 16 08-09-2015 09:41 PM
1994 park av 3.8 stock. egr code and high idle...... meomike2000 Buick 2 06-12-2011 06:18 PM
94 Bonne no power, misfire, stumbling, high idle, trans prob dbusch22 1992-1999 7 03-15-2008 02:04 PM
From rough idle to high idle randman1 1992-1999 25 09-07-2004 09:20 PM
'00SSEi:rough idle,high idle...Please Help.... GTP2SSEi General GM Chat 2 07-29-2003 01:46 PM


Tags
high idle, misfire, stalls

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.