Sub Is Acting Up - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 12-14-2010, 12:06 AM   #11
Senior Member
Posts like a Turbo
 
04MonteLS's Avatar
 
Join Date: Jul 2010
Location: Sacramento, CA.
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
04MonteLS is on a distinguished road
Default

Quote:
Originally Posted by raptor660 View Post
What he said
Ya know man, this is the second time you've said you suspect something being wrong with your sub and were ready to get it reconed not so long ago so ya know what I say..............Put the most powerful amp you have on that **** and bang it out till it can't bang anymore! Have PSI recone it for you, then repeat
04MonteLS is offline   Reply With Quote
Old 12-14-2010, 05:34 AM   #12
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

My buddy has an Old Skool 12" Rockford Power Series that he just had reconed by PSI/Fix My Speaker and it sounds like poopy. I sure it could be his tuning and enclosure but i would prolly just have it reconed by Fi, well i would order a recone kit and do it myself.
And no Dakota i do not abuse it. I was giving it 2300 rms for a bit but it handled it great. No bass boost, all my bass curves are flat. Tuned properly.
And Monte.. Im using the biggest amp i got. LOL.
HOWEVER... I had a guy call me yesterday. wants to trade me:
His BNIB Old Skool PPI PC2350, I believe he said PPI PC650, PPI EQ/crossover, PPI sub, and $200 for my Fi Q with an amp and my 12" Audiobahn Flame Q with an amp.
Those 2350'* are NICE, and are pretty expensive on ebay.
I had a PPI pcx2400, incredible amp!
http://cgi.ebay.com/Precision-Power-...item3f02461a23
raptor660 is offline   Reply With Quote
Old 12-14-2010, 11:06 AM   #13
Senior Member
Posts like a Turbo
 
04MonteLS's Avatar
 
Join Date: Jul 2010
Location: Sacramento, CA.
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
04MonteLS is on a distinguished road
Default

Quote:
Originally Posted by raptor660 View Post
My buddy has an Old Skool 12" Rockford Power Series that he just had reconed by PSI/Fix My Speaker and it sounds like poopy. I sure it could be his tuning and enclosure but i would prolly just have it reconed by Fi, well i would order a recone kit and do it myself.
And no Dakota i do not abuse it. I was giving it 2300 rms for a bit but it handled it great. No bass boost, all my bass curves are flat. Tuned properly.
And Monte.. Im using the biggest amp i got. LOL.
HOWEVER... I had a guy call me yesterday. wants to trade me:
His BNIB Old Skool PPI PC2350, I believe he said PPI PC650, PPI EQ/crossover, PPI sub, and $200 for my Fi Q with an amp and my 12" Audiobahn Flame Q with an amp.
Those 2350'* are NICE, and are pretty expensive on ebay.
I had a PPI pcx2400, incredible amp!
http://cgi.ebay.com/Precision-Power-...item3f02461a23
Out of all the car audio boards I go to and all the psi recones i've seen/heard about, this is the first time i've ever heard anyone say anything negative about anything regarding psi so clearly i'm a little skeptical. There'* alot I don't know about the situation and his setup so I can't come to a conclusion either so it is what it is.
04MonteLS is offline   Reply With Quote
Old 12-14-2010, 05:21 PM   #14
Senior Member
True Car Nut
Thread Starter
 
raptor660's Avatar
 
Join Date: Mar 2010
Location: Eaton Rapids MI
Posts: 2,964
Thanks: 0
Thanked 0 Times in 0 Posts
raptor660 is on a distinguished road
Default

Im sure it has alot to do with his set up and not the sub its self. I just have never seen another PSI sub to compare it to. Im sure if i had them recone it i would be happy with the out come. I know one thing tho, once he had it reconed it was tight! Like the suspension was really tight. U could punch it and it would barely move but thats not necessarily a bad thing
raptor660 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New sub.. Biggest sub ever!!!!!!!!!! No joke! Check this out!!!!! raptor660 Audio (and aftermarket electronics) 18 07-08-2011 08:29 PM
Touring/Perform buttons acting funny Sol 1992-1999 3 05-28-2004 12:25 PM
car acting strange L27Buick Lounge 3 08-22-2003 10:19 AM
car is acting retarded Jeep2Bonny General GM Chat 8 07-12-2003 06:02 PM
HELP!!! 1997 SSEi Wipers Are Acting WEIRD!!! Mr Bean 1992-1999 4 01-21-2003 01:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.